WordPress.org

Ready to get started?Download WordPress

Forums

  1. Moonflux
    Member
    Posted 1 year ago #

    I can't upload a font. The error message is:

    Warning: fopen(/home/moonflux/www/wp-content/plugins/font/fgccookie.txt) [function.fopen]: failed to open stream: Permission denied in /home/moonflux/www/wp-content/plugins/font/Font.php on line 430

    Warning: fclose(): supplied argument is not a valid stream resource in /home/moonflux/www/wp-content/plugins/font/Font.php on line 432

    Warning: file_get_contents(/home/moonflux/www/wp-content/plugins/font/fgccookie.txt) [function.file-get-contents]: failed to open stream: No such file or directory in /home/moonflux/www/wp-content/plugins/font/Font.php on line 434

    Warning: file_put_contents(/home/moonflux/www/wp-content/plugins/font/fgccookie.txt) [function.file-put-contents]: failed to open stream: Permission denied in /home/moonflux/www/wp-content/plugins/font/Font.php on line 472
    You need 4.91 version to upload fonts. Please update on Plugins page of your dashboard.

    Except I'm using version 4.93. My WordPress version is 3.42.
    Also, every time I try to save a font (the menu is very bugged but I can see some fonts), it looks like it's saving, but it doesn't change anything.

    http://wordpress.org/extend/plugins/font/

  2. killerdeveloper
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Moonflux,
    are you using IIS?
    It looks like your server settings are very restrictive and writing permission is disabled on the font plugin folder. Probably same thing for fontfiles subfolder.

    best regards,
    Pawel

  3. Moonflux
    Member
    Posted 1 year ago #

    I've changed the folde permissions and now it's working perfectly. Thank you very much.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.