WordPress.org

Ready to get started?Download WordPress

Forums

Fancier Author Box by ThematoSoup
[resolved] Plugin not showing up in posts at all? (34 posts)

  1. ianizaguirre
    Member
    Posted 10 months ago #

    My author box does not appear at all in any of my posts. I have checked that selection in the settings. My Website is

    IamDentistry.com

    Please help me, it seems like an amazing plugin

    http://wordpress.org/extend/plugins/fancier-author-box/

  2. Dragan Nikolic
    Member
    Plugin Author

    Posted 10 months ago #

    1. Would you please update all your plugins (Fancier Author Box included), your WordPress is already up to date.

    2. Could you set it so it shows on pages, posts and custom post types if you have them? Just to make sure it doesn't show on any of these.

    3. See that nothing is blocking java-script execution (disable any security or cache plugins).

  3. ianizaguirre
    Member
    Posted 10 months ago #

    I deleted the plugin and reinstalled the newest one. It works on my posts only when I have show on pages active. I am guessing its treating my posts as pages? it does not show when I have only posts active which is what I want

  4. ianizaguirre
    Member
    Posted 10 months ago #

    any ideas how to fix this I just want it to show on my posts ?

  5. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    Could you post a link to your website?

  6. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    Sorry, just saw it now, looking into it.

  7. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    I'm looking at this URL (in blog):

    http://iamdentistry.com/why-should-you-focus-on-compound-exercises/#.UajjnWT72gY

    And for some reason it's treated as if it were a page (it has single-page class assigned to <body> element), this is either caused by the theme or another plugin. Could you preview the site with default theme and Fancier Author Box set to appear only in posts?

  8. ianizaguirre
    Member
    Posted 10 months ago #

    I discovered the plugin I had that caused this problem right now.

    It is "Custom Post Type Page Template" Version 1.0 | By Hiroaki Miyashita

    Here is the link to that plugin
    http://wpgogo.com/development/custom-post-type-page-template.html

    (its in Chinese I think I used internet explores translate page to read it)

    I liked having this option though, It would be a shame to have to get rid of it. For some reason it must treat my posts like pages? any way around all this ?

    Thanks for all of your help

  9. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    I'm afraid you'd have to get in touch with Custom Post Type Page Template to see how this could be fixed. I wish I could be of more help.

  10. ianizaguirre
    Member
    Posted 10 months ago #

    haha there Chinese! Guess I have to get rid of the other plugin. Would buying the fanciest author box, be any different like would it fix my issue?

  11. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    Honestly, I doubt it, since it's the same mechanism that adds author box to posts.

  12. ianizaguirre
    Member
    Posted 10 months ago #

    Ok thanks for your help, O and I noticed that when someone clicks on Bio or more posts the entire page scrolls down automatically? Is there a way to prevent this?

  13. ianizaguirre
    Member
    Posted 10 months ago #

    and also is there any code I can put in my child theme to change the color of the ts-fab-header ( the color of the authors name) I don't want to keep it like the color of the rest of my links.

  14. Dragan Nikolic
    Member
    Plugin Author

    Posted 10 months ago #

    Per page scroll - Please see if you can deactivate Smooth Scroll plugin or a feature in your theme that does this.

  15. Dragan Nikolic
    Member
    Plugin Author

    Posted 10 months ago #

    As for the code for h4 headings in author box, here's what you need to add to your theme's CSS:

    .ts-fab-wrapper a {
    color: #000!important;
    }

    You can change the hexadecimal value to change the color.

  16. ianizaguirre
    Member
    Posted 10 months ago #

    hmm this code

    .ts-fab-wrapper a {
    color: #46A5E5!important;
    }

    It works because it changes the color of the author name BUT it also overrides the color of the words for "BIO" and "Latest Posts" making them the same as the authors name. Any way to fix this?

    And as for the per page scroll the only plugin that comes to mind that has that feature is my "Table of Contents Plus" Plugin but I don't see why it would affect this plugin? this only happens when I put the Table of contents on a page and a user clicks on one of the Table of Contents Links? This is strange ?

    Thank You for keeping on helping me I really Appreciate it.

  17. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    Try this:

    .ts-fab-header h4 a {
    color: #46A5E5!important;
    }
  18. ianizaguirre
    Member
    Posted 10 months ago #

    Hey thank you that worked perfectly, any ideas on the whole scroll problem? is there any CSS I can add to prevent this?

  19. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    I think this is caused by Table of Contents plugin, could you try temporarily disabling it to see if that fixes the problem?

  20. ianizaguirre
    Member
    Posted 10 months ago #

    yes it is that plugin, I want to keep it, though, is there anyway around this? and I noticed that on some other computers useing internet explorer that my picture in the fancy author box appears very skinny and you cant see it at all?

  21. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    You'd have to get in touch with Table of Contents author to see how to disable smooth scrolling for links that are not part of table of contents.

  22. ianizaguirre
    Member
    Posted 10 months ago #

    ok I will, but what about the author box not being readable and appearing supper skinny on some computers iv looked at my website through? all using Internet explorer?

  23. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    The entire box, or just the avatar?

  24. ianizaguirre
    Member
    Posted 10 months ago #

    just the avatar - the box, the words, and the links look perfect

  25. ianizaguirre
    Member
    Posted 10 months ago #

    the avatar looks like a skinny line and you cant see the picture because its so skinny

  26. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    Got it, thanks, we'll look into it, but if you could, please try adding this to theme's style.css:

    .ts-fab-avatar img { display: block; width: 64px; height: 64px; }

  27. ianizaguirre
    Member
    Posted 10 months ago #

    ok I add that to my child theme? or your plugin style sheet?

  28. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    Child theme would be best.

  29. ianizaguirre
    Member
    Posted 10 months ago #

    ok i added it but it still skinny on my dads computer?

  30. Slobodan Manic
    Member
    Plugin Author

    Posted 10 months ago #

    We're looking into it. Could you let me know which IE version it is?

Reply »

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.