WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] plugin not correctly updating on wp.org (2 posts)

  1. Ammaletu
    Member
    Posted 2 years ago #

    Hi!

    I feel a bit stupid posting here, but haven't found any information about where else to ask. When people ask this kind of question on the wp hackers list, they get referred elsewhere, but I can't seem to find any of these infrequent threads right now. Anyway, someone hopefully knows.

    I created a new release 0.2 for my plugin:
    http://wordpress.org/extend/plugins/avatar-privacy/

    This worked only halfway. The page offers the new 0.2 zip file, but the button still reads "download version 0.1" and there's no update notification in any of my blogs. It's been over a day so I think the problem is not temporary.

    So, who could possibly fix this and why is there no clear contact information for plugin authors? Thanks for any help. :-)

    Greetings,
    Johannes

  2. Ammaletu
    Member
    Posted 2 years ago #

    So, it turns out I fell for a beginner's mistake. I updated the 'stable tag' entry in the readme.txt in trunk correctly, but forgot to change the 'Version' header field in the main PHP file of the plugin. So wordpress.org read the main PHP file in the tag director and found the version 0.1 there. Thinking, this tag directory contained a version 0.1 of the plugin, the button text was not changed and nobody got an update notification, even though the download was otherwise correct.

    Thanks to Otto for a super-fast answer on my question! He did a nice write-up of this and other possible mistakes:
    http://make.wordpress.org/plugins/2012/06/09/the-plugins-directory-and-readme-txt-files/

Topic Closed

This topic has been closed to new replies.

About this Topic