WordPress.org

Ready to get started?Download WordPress

Forums

NoSpamNX
[resolved] How to not block a part of a word? (16 posts)

  1. Abcmoteur
    Member
    Posted 2 years ago #

    Hi,

    I like your plugin, it is the best way I found.

    However, I wonder how to block words without a part.

    For example, NoSpamx will block "getting" and "get" for "getting". Sometimes, it's annoying.

    I use words like "you" because my visitors are french and I don't want english comments on my blog who are often spam. But "youtube" is already blocked.

    Any idea?

    http://wordpress.org/extend/plugins/nospamnx/

  2. kubi23
    Member
    Plugin Author

    Posted 2 years ago #

    Well, i see two options:

    1.) add a global flag to either check part of words or the complete word.

    2.) add a flag per word to either check it completly or a part of the word.

    My first impression would be no. 1. What do you think?

  3. Abcmoteur
    Member
    Posted 2 years ago #

    Could give an example? I don't know how to add a flag.

  4. Abcmoteur
    Member
    Posted 2 years ago #

    Up!

  5. kubi23
    Member
    Plugin Author

    Posted 2 years ago #

    Version 5.1.1 has an option to whether match full Words or Substrings for local an global blacklist.

  6. Abcmoteur
    Member
    Posted 2 years ago #

    Amazing! Many THANKS! :))

  7. Abcmoteur
    Member
    Posted 2 years ago #

    Hum NospamNX doesn't work since upadate.
    I have "here" in local blacklist but comments with this word isn't blocked.

    Thx.

  8. kubi23
    Member
    Plugin Author

    Posted 2 years ago #

    I just double-checked. Both Substring and exact word match works. In which field (author, email, comment, etc.) do you put "here"?

  9. Abcmoteur
    Member
    Posted 2 years ago #

    I downgraded plugin and I updated and it seems to work.

  10. Abcmoteur
    Member
    Posted 2 years ago #

    "Here" was in comment field

  11. kubi23
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry, still can't reproduced your error, even with "here" in the comment fields. All tests I did worked.

  12. Abcmoteur
    Member
    Posted 2 years ago #

    I said NoSpamNX seems to work now with lastest version.

  13. Abcmoteur
    Member
    Posted 2 years ago #

    Hum... Nospamnx doesn't work. I put "you" and comments with "you" in comment field are not blocked.

    I try also with me.

  14. MickeyRoush
    Member
    Posted 2 years ago #

    If you want to block words better, use the Better Moderation plugin:

    http://wordpress.org/extend/plugins/better-moderation/

    With it you have better control over the words with anchors '^'

    For example:

    You want to block just the word 'you'

    ^you^

    That will only block 'you' and nothing else. Youtube for example wouldn't be blocked. If you were to use '^you' that would block Youtube as well as anything that starts with you. You can put an anchor '^' in front, in back, or both.

  15. Abcmoteur
    Member
    Posted 2 years ago #

    Hum I just try with a blog test and it's work.
    How can I uninstall properly nospamnx?

  16. Abcmoteur
    Member
    Posted 2 years ago #

    Hi,

    any idea? Just "Match Substrings" mod work. If I uncheck all spam aren't blocked.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags