WordPress.org

Ready to get started?Download WordPress

Forums

Ninja Announcements Lite
[resolved] HTML Code coming through Manual Insertion (10 posts)

  1. travis.hill
    Member
    Posted 2 years ago #

    Upon creating and activating an announcement, I have noticed HTML code coming through on the front end.

    < class='ninja-annc-entry'>

    This is showing, coming from display.php line 1173.

    http://wordpress.org/extend/plugins/ninja-announcements/

  2. James Laws
    The WP Ninjas
    Plugin Author

    Posted 2 years ago #

    Could you provide a link so I can see this behavior in action?

  3. travis.hill
    Member
    Posted 2 years ago #

    Replacing display.php line 1173 with:

    $output .= "<div class='ninja-annc-entry'>$content</div>"; has provided a temporary patch.

    It seems the $content_wrapper = $meta['content_wrapper'] isn't being pushed to this code.

    WordPress 3.3.1
    WooThemes Canvas

  4. James Laws
    The WP Ninjas
    Plugin Author

    Posted 2 years ago #

    Thanks for the heads up. I'll look into it further and get it patched.

  5. travis.hill
    Member
    Posted 2 years ago #

    Wow, that quickness was a taste of awesomeness. Thanks!

    I've reverted back to the original code and taken a screenshot (the announcement is only visible to logged in members).

    You may view it here.

    If you need access, I will be more than happy to provide it to you!

    Thanks again!

  6. James Laws
    The WP Ninjas
    Plugin Author

    Posted 2 years ago #

    Ha! Thanks. One of my pet peeves with plugins and such is never hearing from the developer no matter what the issue might be. We are trying to respond as fast as possible whether we have an immediate answer or not. That way you at least know we saw it and are aware of the issue.

    We probably won't need access. The info you provided was perfect debugging this issue I believe but if we do we will definitely reach out to you.

  7. travis.hill
    Member
    Posted 2 years ago #

    Excellent.

    Thanks Again!

  8. James Laws
    The WP Ninjas
    Plugin Author

    Posted 2 years ago #

    @travishill, when did you download this last. The reason I ask is when we initially uploaded 2.0 there were some SVN issues and we ended up doing a bunch of micro updates to fix some errors because of that.

    All that is to say that if you downloaded this on Thursday a fresh download might already correct that issue. It's just something that might fix the issue why we get ready to look at the code and debug. :)

  9. travis.hill
    Member
    Posted 2 years ago #

    Long story short - I auto-updated sometime last week.

    On a bright note - a fresh download of the .zip and upload seems to have corrected the issue. I haven't dove into the code, however the HTML (that was causing the issue) isn't coming through. So, whatever it was is resolved!

    Thanks again for your super quick responses and help.

  10. James Laws
    The WP Ninjas
    Plugin Author

    Posted 2 years ago #

    Awesome! We'll still be digging in a bit to make sure that all is well but glad that the fresh download cleared up your issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic