WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Scroll Gallery
Error on page: Warning: Division by zero in.. (16 posts)

  1. mary-rtd
    Member
    Posted 1 year ago #

  2. mary-rtd
    Member
    Posted 1 year ago #

    error gone! ??

  3. orbie
    Member
    Posted 1 year ago #

    I have the same problem, it's displaying that message error in the top of the post i tried the plugin :

    Warning: Division by zero in /home/orbie/public_html/portfolio/wp-content/plugins/nextgen-scrollgallery/nggScrollGallery.php on line 296

    i looked at that line and the line look ok :
    $newimagewidth=($imgwidth/$imgheight)*$newimageheight;

    i don't understand ...
    How can i fix it ?

    thank you !

  4. trevorama
    Member
    Posted 1 year ago #

    I'm also having this problem.

    Anyone have a fix?

  5. Benedikt Mo
    Member
    Plugin Author

    Posted 1 year ago #

    Hm, seems that variable newimageheight is null or 0.
    Witch version of nextgen Gallery do you have installed?
    The newest one?

  6. orbie
    Member
    Posted 1 year ago #

    yeah, last week, the latest version :(

  7. orbie
    Member
    Posted 1 year ago #

    oups, sorry nextgen gallery was not up to date, i juste updated it
    it's nextgen scroll gallery that was the last version

    NextGEN Gallery
    Version 1.9.12

    NextGEN Scroll Gallery
    Version 1.8.1

    i'll try again with your plugin in the page wich causes problem

  8. orbie
    Member
    Posted 1 year ago #

    still not working :
    Warning: Division by zero in /home/orbie/public_html/portfolio/wp-content/plugins/nextgen-scrollgallery/nggScrollGallery.php on line 296

    but it do work on some pages and not on others, that's strange

  9. Benedikt Mo
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Orble,
    thanks for your fast reply.
    Ok. I think the problem is, that one or more of your images in your nextgen gallery has no correct hight information in the database.
    Please go to your nextgen admin interface and open the gallery with the problem.
    Please check if all images has a width and hight information under their title.
    Normally each image has a title, a date and a dimension, for example:

    "Karlsruhe at night
    18. Juni 2011
    532 x 800 pixel"

    I think one or more images has no correct size information in the database.
    If you find such images in your gallery. Try to upload that images again.
    Regards Benedikt

  10. orbie
    Member
    Posted 1 year ago #

    I'll look for that :)
    Thank you !

  11. frednat
    Member
    Posted 10 months ago #

    Note I tried what Benedikt Mo said, but all my images appeared with the correct width and height information. I was still getting all the eroor messages about dividing by 0.
    HOWEVER I did a bulk "Import Metadata" in the NextGenGallery "Manage Gallery" area for all the images, and voila! scrollgallery now works.

    Happy days.

  12. lordxtina
    Member
    Posted 10 months ago #

    ^ @frednat: Thanks so much! How lucky I am that you posted just a day ahead of me!

  13. mustermann
    Member
    Posted 10 months ago #

    Hi,
    I´m using NextGen Gallery Version 2.0.27 and NextGEN Scroll Gallery Version 1.8.1.

    Since update to Version 2.0.27 an new galleries I get with Scroll Gallery Version 1.8.1. many warnings (one for every picture!)

    Warning: Division by zero in /www/htdocs/.../.../wp-content/plugins/nextgen-scrollgallery/nggScrollGallery.php on line 296

    All pictures in the new gallery have a title, a date and dimension, Alt & Title Text / Description and Tags (comma separated list)

    Without NextGEN Scroll Gallery and the shortcode [nggallery id=xx template=caption] the pictures are seen on the page.

    Thank you for help

  14. dtrcka
    Member
    Posted 10 months ago #

    Thank you @frednat it worked for me too. this was the quickest problem that I solved with WP. nowadays it seems that I spend twice as much formating and fixing than actual writing.

    @Benedikt Mo nice plugin, have been using it for about a year.

  15. HeidiMicro
    Member
    Posted 9 months ago #

    Hi,

    I just updated my word-press to 3.6.1 and have the latest version of the
    Gallery.

    @Benedikt Mo - All the images have correct info
    @frednat - did what you suggested, but didn't work

    This is the exact error that I'm getting. You can see it at our homepage microbiz.org

    Warning: Division by zero in /home/content/m/i/c/microbiz/html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/adapter.nextgen_basic_slideshow_controller.php on line 35

    HELP!!!

    Thanks,
    Heidi

  16. HeidiMicro
    Member
    Posted 9 months ago #

    FYI - I re-installed 1.9.13 and don't get the error and have my gallery back

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic