WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] What's the alternative when allow_url_fopen is disabled? (15 posts)

  1. Suncokret
    Member
    Posted 6 years ago #

    My host disabled allow_url_fopen feature for security reasons and now NextGEN gallery doesn't want to add a watermark picture, even though it's on the same server as the site.

    Is there anything I could do to override this? It's ridiculous. At least, is it possible for NextGEN team to make a cURL version instead of a_u_fopen?

    Thanks!

  2. Suncokret
    Member
    Posted 6 years ago #

    Anyone?

  3. Ivovic
    Member
    Posted 6 years ago #

    tried posting this on their site?... or at least in the plugin forum here?

    This isn't really a question for anyone but the plugin author, as far as I can tell.

    Also, I think that's a bit silly on the part of your host.

  4. Suncokret
    Member
    Posted 6 years ago #

    Author temporarily disabled the official nextgen forum. :(

  5. WhisperT
    Member
    Posted 5 years ago #

    Has anyone found an answer to this problem? I was able to apply watermarks before the latest upgrade, but now I can't. I have made sure that fopen is enabled and according to php info in every directory it is ON, but the plugin still claims it is off and will not apply the watermarks. I'm considering downgrading for now to see if that fixes it for now, but I would really like to know what happened.

  6. Suncokret
    Member
    Posted 5 years ago #

    The main problem is - developer is not responding.

  7. Alex Rabe
    Member
    Posted 5 years ago #

    You don't need allow_url_fopen , it should work if you enter the absolut path on your server...

  8. WhisperT
    Member
    Posted 5 years ago #

    Awesome thank you Alex that worked.

    BTW those of us that know the amount of work you have put into this do not at all believe you are neglecting it. This is an amazing gallery plugin. I've been using it ever since the first release and am always impressed with how it has grown.

    Good job, and remember holler at us if you ever need a hand.

  9. Alex Rabe
    Member
    Posted 5 years ago #

    Thanks a lot !

  10. Suncokret
    Member
    Posted 5 years ago #

    Hey thanks it worked!!

    Just to make sure everyone understands!

    Here's the simple php program that locates the exact absolut path:

    <?php
    $path = getcwd();
    echo "Your Absoluthe Path is: ";
    echo $path;
    ?>

    Copy/paste the above lines, save the file whatever.php and upload it to the same directory where you put your watermark file.
    After that start that PHP file in your browser and copy the given address.
    Then go to Gallery/Watermark and instead of URL paste the address.

  11. adambundy
    Member
    Posted 5 years ago #

    Alex, Im having trouble making the watermark image feature work. Ive used the abs. path to the image file and get back a success message both on setting the preference for the watermark image and on setting the watermark to an image in the gallery, but nothing shows up. Im on MT gridserver and have set allow_url_fopen=1 in the .ini. Any tips??
    Thanks for the great plugin, -Adam

  12. Alex Rabe
    Member
    Posted 5 years ago #

    Do you use a png file as watermark ? Only this file is working

  13. adambundy
    Member
    Posted 5 years ago #

    Ahhh! Thanks for that Alex- a tip to that effect under the filepath field would be great. Thanks again- great plugin!

  14. Alex Rabe
    Member
    Posted 5 years ago #

    You are right I will add this in the next version

  15. Patrick Beuken
    Member
    Posted 5 years ago #

    Thanks for your post, Suncokret!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.