WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Voting
[resolved] Stars not showing after update (23 posts)

  1. Bruxo
    Member
    Posted 1 year ago #

    Hi,

    I have updated the plugin today, and now stars are not showing anymore. Instead, bulleted text lines: "Currently 4/5 Stars. 1 2".

    It seems that it could be an issue with plugin CSS? Any solution?

    Thank you.

    http://wordpress.org/extend/plugins/nextgen-gallery-voting/

  2. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Bruxo
    That does sound like a CSS issue. Is there a link I can see of the problem, as it seems to be working on my test installs?

  3. lucianmih
    Member
    Posted 1 year ago #

    I have the same issues with stars not showing after updating to v.2.0

    You can see here:
    http://sidelinesnews.com/general/holiday-horses-contest.html

    If you look in the source code, the URL for star images appear like this:
    <img class="nggv-star-loader" src="http://sidelinesnews.com/wp-content/plugins/__DIR__//images/loading.gif" style="display:none;" />

    Seems like __DIR__ is not replaced with the current plugin path.

    Thanks!

  4. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the link, and even doing some of the debugging for me :)
    Turns out the PHP super global __DIR__ was only added in PHP 5.3. I have replaced it with more compatible code and pushed out release 2.0.1.

    Please let me know once you've updated if there are any more issues.

  5. lucianmih
    Member
    Posted 1 year ago #

    Thanks for the quick fix, Shauno!

    I got the 2.0.1 and the stars work fine now.
    http://sidelinesnews.com/general/holiday-horses-contest.html

  6. Pgraz01
    Member
    Posted 1 year ago #

    Another question!
    Where I've to go to change the theme i use to be able to see poll's coloured stars instead of one white arrow into a blue square? I try a different themes and the plugin works fine (grat work Shauno!!!) but I can't change it now :-((
    Can you help me (even if this is a silly question)?
    Thanks a lot

  7. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Pgraz01

    I'm not sure I understand the question. It sounds like you want to change the look of the stars. Unfortunately there are no pre-set themes, and you would need to edit the CSS and images yourself.

    I hope that helps.

    PS. Next time please start you're own thread for new questions.

  8. Pgraz01
    Member
    Posted 1 year ago #

    Yes! Thanks!
    I've changed the image and edit the css.
    now every thing is ok.
    Great!

  9. Samuel
    Member
    Posted 1 year ago #

    Hi,
    I ve about the same problem with the last 2.0.1 release the stars are shown just only for gallery vote and not on the single images. The vote is enable for each image with unlimeted votes and for all users. I checked the source and all i can but didn't find a reason for this.

    You can see it here
    http://samuelweb.netsons.org/test/

  10. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like you haven't added the tag to the gallery template. I should change the 'Frequently Asked Questions' to 'Things Nobody Reads'...

  11. Samuel
    Member
    Posted 1 year ago #

    Thx for the quick answers,
    You right! i ve installed this plugin 2 months ago in another site and i forgot that passage.

  12. Filipposky
    Member
    Posted 1 year ago #

    Hi!
    I have read the FAQ, put the tag, but after the last update I can not even see the stars .. As can be seen ( http://www.sailrev.com/kiteboarding-il-primo-mondiale/ ) are seen numbers.
    They do not seem to load the css file! How can I do? thanks!

  13. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    I can't replicate the problem in my test environments. I see the CSS isn't being included in your site at all.
    What version of PHP, WP, NGG, and NGGV are you running, and I will try replicate your install

  14. Filipposky
    Member
    Posted 1 year ago #

    Hi,
    it does not seem inclusive.

    Php: 5.3.18 (It is not clear! Might also be 5.2.17)
    WP:3.4.2
    NGG:1.9.6
    NGGV:2.1
    Thanks!

  15. unicawebagency
    Member
    Posted 1 year ago #

    Hi After upgrade to NextGen Voting Pro I don't see stars for each photo http://www.mylabrador.it/foto-calendario-2013/

    Can you help me ?

  16. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Hi unicawebagency
    I have replied in the other thread you started. Lets keep the responses in that thread so it's easier to follow what's going on.

  17. jacobmclaws
    Member
    Posted 1 year ago #

    Shauno,

    I'm having a similar problem with the stars not appearing, but text in its place. I've read this thread, but I can't figure out what's up. Any help would be great.

    Here's the site: http://www.swarmtag.com/swarm

  18. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Hi jacobmclaws

    Didn't you have the plugin working a week ago? If so, what's changed since then?
    You are the second person to show me an example of the CSS and the JS files not being loaded, but I cannot replicated it on my test installs.

    Can you please try one of the WP default themes (twenty twelve for example), and see if it works then?
    If not, can you disabled all your other plugins one by one and re-check the page. If after disabling one of the plugins, it works, please let me know what that plugin is, and I will see if I can get around whatever is conflicting with NGG Voting then.

  19. jacobmclaws
    Member
    Posted 1 year ago #

    Ya. I thought I got it working, but something threw it off again. I'll try deactivating the plugins and let you know what I find out. Thanks

  20. jacobmclaws
    Member
    Posted 1 year ago #

    So I tried disabling each plugin in one by one and nothing seemed to work. it's super strange. I can't think of why it wouldn't be showing.

  21. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Can you try one of the default built in WP themes, for example 'twenty twelve'?

  22. jacobmclaws
    Member
    Posted 1 year ago #

    I'm afraid it will mess up my buddypress setup when I try to switch back... I'll try to keep tinkering.

  23. jacobmclaws
    Member
    Posted 1 year ago #

    Has anyone else had this problem. Any solutions? Still stymied...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic