WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Voting
Not working with [nggtags] shortcode (8 posts)

  1. migf1
    Member
    Posted 3 years ago #

    Hello,

    I've already stated the problem in another topic, but I didn't get any answers, so I'm making a new one.

    In short, voting works as expected for images when displaying them via the [nggallery ...] shortcode, but it brakes when the images are displayed via the [nggtags ...] shortcode (it displays the ratings but when trying to vote, it shows an error message, saying to try later... but it never works).

    I tried to find out which .php file handles the tags output in NGG (either template or core file) in order to add the call to the voting function, but I didn't have any luck.

    Any help would be greatly appreciated!

    http://wordpress.org/extend/plugins/nextgen-gallery-voting/

  2. shauno
    Member
    Plugin Author

    Posted 3 years ago #

    Hey migf1

    I saw your post in the other topic, but forgot about it as that topic was about a different problem.

    Thanks for the feedback, there definitely seems to be a conflict somewhere when using the [nggtags] shortcode. I will try have a look at it sometime this week and get a patched version released asap.

    Thanks again for a the heads up :)

  3. migf1
    Member
    Posted 3 years ago #

    Thank you very much, I really hope you can fix it :)

    Best regards!

  4. shauno
    Member
    Plugin Author

    Posted 3 years ago #

    Hey mig

    I had some time to take a peak at that code today. Turns out there was just a simple conflict with variable names when using that shortcode.

    I have renamed the affected parts and committed the changes (1.7.1). Let me know if that sorts out your problem!

    Cheers
    Shauno

  5. migf1
    Member
    Posted 3 years ago #

    Good morning, thank you very much for your efforts to improve this very useful plugin! It now works with [nggtags], however it seems to still have some issues.

    I'm using my own set of icons for the stars, which visually get corrupted on mouseover when in [nggtags] output screens (I haven't tried with the default stars yet, but in [nggallery] output screens they work nicely).

    The most important issue though is that when one rates any image in [nggtags] genertated screens, the registered vote is always one star short (i.e. if you rate an image with say 4 stars, it registers the vote as 3 stars, and so on.)

    You can see an example of the above in the following links (they are form my site). The first one is a normal [nggallery] output screen, while the 2nd one it is generated via the [nggtags] shortcode:

    1. [nggallery] output
    2. [nggtags] output

    I'm really excited about this plugin and I'm really happy you keep supporting it!

    Best regards.

  6. shauno
    Member
    Plugin Author

    Posted 3 years ago #

    Hi again mig

    I had a look at your pages, and I see what you mean about the ratings. It looks as though there is a width or something wrong somewhere in the CSS. It loads and works fine on my test installation (with the original stars).

    I see you have obviously used your own stars graphic. But Unfortunately I actually don't really know enough CSS to see any errors. I will chat to a friend that specializes in this later in the week, and see if there is a conflict somewhere when using different graphics with [nggtags] that he can spot.

    Sorry about the problems, I really do appreciate the feedback though.

    I will let you know once I know more!

  7. migf1
    Member
    Posted 3 years ago #

    Hello, thank you for keep looking into it! I just tried with the default plugin settings but it was not working right. It could be that I have also tweaked ng-gallery's css (dunno).

    Since I managed to screw up everything (lol) I have temporarily deleted ngg-voting. I will install it again when I have more free time to fiddle with it again, and I'll let you know.

    If you find anything in the meanwhile, I'd be happy to hear about it ;)

    Best regards.

  8. shauno
    Member
    Plugin Author

    Posted 3 years ago #

    Hey mig

    Thanks for the update. I did have a brief look, but I can't understand why it would work with one shortcode and not the other. It might be another conflict in some way with the NGGs css, but I can't be too sure.

    I did notice a bug in that the css is being included repeatedly. I will have a patched version out pretty soon, but I don't think that was the problem in your case.

    If you do try to enable everything again, let me know how it goes. I definitely don't like bugs lurking around in my code :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic