WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Usertracking: Please remove Twitter and Facebook-Buttons (7 posts)

  1. gerobe
    Member
    Posted 2 years ago #

    Hello,

    I think neither Facebook nor Twitter should know, what I do in my WordPress-Backend. Please remove those user-tracking-buttons (aka Tweet- and Like-Button) from the plugin or offer and option to do so for privacy reasons.

    Greetings
    Gero

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. admintiger
    Member
    Posted 2 years ago #

    I agree! It is reckless to load JavaScript code located on a Facebook server in web browsers logged-in to the WP admin system. I stripped out all code related to that and to the creation of unwanted Twitter and Facebook links. I haven't tested the modified version extensively, but it seems to be running normally at several websites.

    I have posted the modified version here for others who want to use it instead of the official release.

    Of course, the changes will be overwritten if a newer version from Photocrati Media is subsequently installed, so this is only a temporary solution. Now that Photocrati Media has violated user trust by doing this I have created a new branch that I will upgrade over time for my own use, but I probably won't be making it available to others, because I don't have time to provide technical support.

  3. terminalcity
    Member
    Posted 1 year ago #

    I agree- the Twitter icon is really irritating and it does not belong there.

    I got rid of all of them with this hack, although you have to do it for every page where the icons appear.

    - Open the files overview.php, manage-galleries.php, addgallery.php etc in the NextGen admin folder
    - search for an remove this line:
    <?php include('templates/social_media_buttons.php'); ?>

    Voila! No more twitter/facebook etc.

  4. gerobe
    Member
    Posted 1 year ago #

    Thank you terminalcity!

    Too bad, that you have to do this with every update.
    There was an update to the plugin a few days before, but the icons were not removed or there was no new option to do this.

    No good sign, that the new owners of the plugin really care about customer opinions and facebook-likes are more important to them than customer privacy :(

  5. kakohari
    Member
    Posted 1 year ago #

    Guys, it is much easier than removing all the lines.
    Go to the plugins-Folder, /nextgen-gallery/admin/templates/
    Edit the file social_media_buttons.php from

    <div id="ngg_social_media">
    	<?php include('twitter_follow_link.php'); ?>
    	<?php include('facebook_like_button.php'); ?>
    </div>

    to

    <div id="ngg_social_media">
    	<?php // include('twitter_follow_link.php'); ?>
    	<?php // include('facebook_like_button.php'); ?>
    </div>

    This comments the include-lines out an neither facebook nor twitter will be loaded.

    Feel free to mark as "resolved" if this resolves your issue - my installations are antisocial now ;-)

    Of course this is not update-safe, but easily done.

    Edit: typo

  6. Zoinks! Graphics
    Member
    Posted 1 year ago #

    Thanks, terminalcity and kakohari for providing an at least temporary solution!

    We can also edit the /nextgen-gallery/admin/templates/social_media_buttons.php file to

    <? /*
    <div id="ngg_social_media">
    	<?php include('twitter_follow_link.php'); ?>
    	<?php include('facebook_like_button.php'); ?>
    </div>
    */ ?>

    That also removes the enclosing div tag. Aside from the security issues, now the NGG portions of my WP admin actually load FASTER.

    I'm amazed that Photocrati Media is risking their NextGen brand by not making display of the social code optional. I sure wish there were an update-safe way to do this using functions or hooks or some such snappy code. Anyone else come up with another solution?

  7. nwdwp
    Member
    Posted 1 year ago #

    Try this solution. It works even after updates and its really simple. I use these heavily when "cleaning" up the display for clients.
    Add this to your child themes style.css sheet.

    #ngg_social_media {
    display:none;
    }

    Best Regards,
    [Signature moderated]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic