WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: NextGEN Gallery] Thumbnails not displaying properly in IE8 (10 posts)

  1. leviticus
    Member
    Posted 4 years ago #

    The thumbnails on the gallery pages are not displaying properly in Internet Explorer 8. In other versions of IE and in Firefox they display correctly as squares, but in IE8 the thumbnails are squished vertically.

    This problem seems to only be happening on the [nggallery id=7] short code, not the [album=3,compact] or the widget.

    http://www.rutlandnd.com/community/photo-albums (working properly)
    http://www.rutlandnd.com/community/photo-albums/historic/people (not working properly in IE8)

    I am using WordPress 2.8.1 and NextGEN Gallery version 1.3.4

    How can this problem be fixed?

  2. GeekSpecialties
    Member
    Posted 4 years ago #

    I'm having the same issue with IE8.
    I added this to an IE8 conditional comment.

    .ngg-gallery-thumbnail {width:160px;padding-right:10px;}

    Set the width to whatever your gallery thumbnails are plus any padding you have on the image.

  3. leviticus
    Member
    Posted 4 years ago #

    That solved the problem. Thanks!

  4. js09
    Member
    Posted 4 years ago #

    fixed it for me too, thanks

  5. nathanmckenna
    Member
    Posted 4 years ago #

    Hi guys, really need help with this. How can I set a IE8 conditional comment? What file do I edit, etc...

    I'm trying to control the gallery here: http://www.jasfree.com/inspiration/

    If you're using IE8 you can see that my thumbnail round corners aren't working right because the image in the thumbnail has been moved down by IE.

    I guess I could set up a seperate CSS sheet but I need to know how to use a conditional comment.

    please help.

  6. yoyogliderpilot
    Member
    Posted 4 years ago #

    You can ad the code in your CSS. Then it will be the same for all browsers.

    .ngg-gallery-thumbnail {
    width:100px;
    padding-right:10px;
    }

    Make sure the width is the same as in Gallery > Options > Thumbnail settings.

  7. wwg
    Member
    Posted 4 years ago #

    Just wanted to say thanks... I was having the same issue with IE8 showing gallery thumbnails long and vertical, stacked. (Was perfect in FF, Opera and Safari)

    Adding the width and padding above to nggallery.css (found in /wp-content/plugins/nextgen-gallery/css/) worked like a charm!

  8. nilsnh
    Member
    Posted 3 years ago #

    Thanks yoyogliderpilot for that snippet of enlightenment. :)

  9. tr1guy
    Member
    Posted 3 years ago #

    FANTASTIC! Thank you for this fix! As a "newbie" to CSS, I am so glad for help like this. Now, the thumbs look great in IE.

  10. chrisdoth
    Member
    Posted 3 years ago #

    Thanks for the help.

    Not really resolved for me, as it now means all my gallerys have to have the same size thumbnails.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags