WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Thumbnails displaying in one vertical column (15 posts)

  1. colormecolorado
    Member
    Posted 2 years ago #

    Hi all,

    No matter WHAT I try, the thumbnails on my page are displaying in one vertical column, instead of rows:

    http://www.pawsforpeople.org/children/paws-for-reading/reading-paws

    I have tried editing the .css in the 'Style' option, editing gallery.php, adding "template=compact" to the shortcode, and absolutely nothing is working. I've read all of the support forums for help, and none of the suggestions seem to solve my issue!

    Can anyone give me some assistance? Thanks, in advance!

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. colormecolorado
    Member
    Posted 2 years ago #

    I've also tried resetting my galleries to default - that didn't work either.

    It looks the same on multiple browsers (Firefox, Google, IE, mobile), so I know that's not the issue.

  3. popopril
    Member
    Posted 2 years ago #

    .widget {overflow:hidden}
    .widget img {float:left; margin: 2px 4px;display:block;}

    Add this to custom.css, it will work for all widget sections

  4. popopril
    Member
    Posted 2 years ago #

    the problem is the theme not in plugin ;-)
    I got the same before and found ;-)

  5. saamadams
    Member
    Posted 2 years ago #

    Forgive me for my ignorance, but do you mean to first go to:

    Style editor, then scroll to:

    sidebar widget, then replace:

    .widget {overflow:hidden} with:

    .widget img {float:left; margin: 2px 4px;display:block;}

    or do we place this entire code:
    .widget {overflow:hidden}
    .widget img {float:left; margin: 2px 4px;display:block;}

    anywhere into the Style editor?

    Thx

  6. colormecolorado
    Member
    Posted 2 years ago #

    I tried the .widget code edit in the style sheet, but it still didn't work for me. My page even cuts my images off:

    http://www.pawsforpeople.org/children/paws-for-reading/reading-paws

    I want to scream!!!

  7. colormecolorado
    Member
    Posted 2 years ago #

    I've also tried using the default style, but the images still show up in a vertical line.

  8. Kayhynn
    Member
    Posted 2 years ago #

    I'm having the same issue with my theme. Any help finding a fix for this in the next day or two would be great. I love this plugin and don't want to switch to another one, but the theme is what my client wants and I need something that works.

    And before anyone asks, this is on pages, not sidebar, so the widgets code does not apply.

    Thanks

  9. saamadams
    Member
    Posted 2 years ago #

    Here is what my husband had me do. Go to: http://www.w3schools.com/. Then to the side bar menu, click on: Learn HTML. Then click on HTML tables. The website will literally walk you through adding a code into your "editor" portion of your WP site to change your single row photos into rows and columns. Personally, I am terrified of screwing around with codes...but even I could do this and it works!!!
    Here is the actual link to the titorial page on tables:
    http://www.w3schools.com/html/tryit.asp?filename=tryhtml_tables

  10. colormecolorado
    Member
    Posted 2 years ago #

    Saamadams - thanks - where specifically in my 'Style' editor for the gallery should I add this code?

    Sorry - I'm a newbie!

  11. saamadams
    Member
    Posted 2 years ago #

    Colormecolorado - hi. I actually made these changes on the actual page where the problem was. I have an e-ccommerce site and my product photos were all lining up-looked ridiculous. So I actually went to the page itself and switched my view to html and followed the w3schools method on adding the proper coding before and after my pictures to make my photos line up in perfect rows and columns. BTW, I'm a newbie too and will probably always be, ha!!

  12. jmek
    Member
    Posted 2 years ago #

    I'm having this problem as well. Everything was working well with WordPress 3.1.2 and NextGen 1.8.4--galleries displayed in nice rows. When I upgraded to WordPress 3.3.1 and NextGen 1.9.2, my galleries started to display in a single column when added to a post or page. Oddly, they work correctly (display in rows and columns) when placed in a widget.

    I do know how to create HTML tables, and that is not the problem in my case. NextGen's gallery templates are designed to take care of this sort of layout. I have even tried importing a .php template from an older version of NextGen, but it doesn't work in this version.

  13. colormecolorado
    Member
    Posted 2 years ago #

    jmek - I think this is exactly what happened to us - when the 1.9.2 version was installed, everything got messed up. Is there a newer version we can download that would fix this problem?

  14. jmek
    Member
    Posted 2 years ago #

    I finally found my problem: a conflict with the NextGen Optimizer plugin. I deactivated the Optimizer plugin and my galleries now display correctly (4 images across each row, as my NextGen settings dictate).

    If you're having this problem, you might check for plugin conflicts.

  15. colormecolorado
    Member
    Posted 2 years ago #

    Wow - I feel like a huge idiot. I updated the NextGen Gallery plugin to version 1.9.3, and lo and behold, my thumbnails are in rows now! They're still a bit misaligned, but I'm sure I can fix that.

    http://www.pawsforpeople.org/children/paws-for-reading/reading-paws

    Thanks everyone for all of your assistance - I'm going to go ahead and close this post; hopefully it helps some people. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.