WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: NextGEN Gallery] Thumbnail Format and Page Link Problems for Galleries (6 posts)

  1. texaun
    Member
    Posted 5 years ago #

    After bombing four times, I came to the realization that this post was getting sent to spam hell. All subsequent references to URLs at texaustralian.com replace that domain with the word "DOMAIN" to "protect the innocent."

    To alexrabe or anyone that can help. Thanks in advance for the assistance!

    Switched over from AWSOM to NextGEN and generally love it! Even found the fix for the conflict with WP Shopping Cart and Thickbox in the forum (but gave up on Lightbox and Highslide...no big deal). BTW, I let Instinct Entertainment know about the conflict because it's their bug and it also affects Thickbox in the posts and pages admin input screens.

    I need help on the following three items. Please refer to DOMAIN/dogs/lily/ (aka DOMAIN/?p=9) where I have been testing before full implementation. The following has been tested when all other plugins are activated or deactivated, with several themes and with updated permalinks.

    1.How do I get more appealing gallery formatting than one column? I would prefer 3-4 columns (and 6-7 rows) with some padding. (I limited the photos per page to 4 to test multi-page capability which leads me to the next question). If I must, I'll stick with slideshow and use singlepic where needed to get the right result, but I've got to assume I'm just missing something.

    2. Is nextGEN not compatible with permalink structures other than the default? I use the custom /%year%/%postname%/, but tested it with all common structures and it only worked with the default. I'll switch to default if that's the case, but think this is a compatability issue that should be fixed.

    For more details on why I ask, note the link for page 2 of the gallery is DOMAIN/nggallery/page-9/page-2. I assume it should link to DOMAIN/dogs/lily/page-2. Similarly, I would assume the link for "Click here for slideshow" should be DOMAIN/dogs/lily/slideshow instead of DOMAIN/nggallery/page-9/slideshow. Both current pages are not generated and result in a page not found error. I even went to the extent of setting up a DOMAIN/nggallery folder and chmoding it to 775 to see if that would fix the problem.

    3. How do I remove the "full size" link in thickbox? I format all my photos to proportionate size with maximum 480px height and 640px width. So there is no need for the full size link. I stared down some of the nextGEN files and the thickbox .js and .css files among other things, but they didn't reveal the secret.

    Also, alexrabe assuming you may respond, I'm also implementing wordTube. Any chance of expanding wordTube to use the the JW WMV PLAYER or writing a new plugin to make use of it?

  2. texaun
    Member
    Posted 5 years ago #

    After taking a closer look, is it possible my server configuration is causing items 1 and 2 (as I see nextgen.boelinger.com has a non-default permalink structure)? Here are the server settings:

    * Operating System : Linux
    * Server : Apache
    * Memory usage : N/A
    * MYSQL Version : 5.0.45-log
    * SQL Mode : Not set
    * PHP Version : 4.3.11
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : N/A
    * PHP Max Upload Size : 8M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : No
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    GD support

    * GD Version : bundled (2.0.28 compatible)
    * FreeType Support : Yes
    * FreeType Linkage : with freetype
    * T1Lib Support : No
    * GIF Read Support : Yes
    * GIF Create Support : Yes
    * JPG Support : Yes
    * PNG Support : Yes
    * WBMP Support : Yes
    * XBM Support : Yes
    * JIS-mapped Japanese Font Support : No

  3. texaun
    Member
    Posted 5 years ago #

    Nevermind on #2, that was too easy...I turned off "Activate permalinks" and that fixed that problem. But help on #1 and #3 are still greatly appreciated!

    Bob

  4. texaun
    Member
    Posted 5 years ago #

    So are you all holding out on me hoping I get it? I'm getting there. I solved question #1. A style wasn't activated at the style editor. When I activated the default style, wallah!, a pretty gallery!

    That leaves #3:
    How do I remove the "full size" link in thickbox? I format all my photos to proportionate size with maximum 480px height and 640px width. So there is no need for the full size link. I stared down some of the nextGEN files and the thickbox .js and .css files among other things, but they didn't reveal the secret.

    And, alexrabe assuming you may respond, I'm also implementing wordTube. Any chance of expanding wordTube to use the the JW WMV PLAYER or writing a new plugin to make use of it?

  5. RoseCitySister
    Member
    Posted 5 years ago #

    It's on line #154 in thickbox.js - at least I think that's what you're looking for (I don't know very much Javascript).

  6. texaun
    Member
    Posted 5 years ago #

    And that works!...just need to delete the following except the leading and ending backticks I included to indicate the space at the end of the string. Thanks much rosecitysister!

    + "' id='TB_FullSize' title='Full Size'>Full Size</a>&nbsp;&nbsp;"

    P.S. Then I remembered our dog pedigree jpgs are 768 px tall so I can't do this until I convert them to pdfs. But it may help someone else.

    Case closed!

Topic Closed

This topic has been closed to new replies.

About this Topic