WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: NextGEN Gallery] The Flash Player and a browser with Javascript support are needed.. (21 posts)

  1. Andreas Beer
    Member
    Posted 6 years ago #

    "The Flash Player and a browser with Javascript support are needed.."
    This message is being displayed instead of a slideshow with plugin version 0.92 and 0.93 on WP 2.3.3.

    Slideshow works perfectly with plugin version 0.91

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. Alex Rabe
    Member
    Posted 6 years ago #

    Please post a link as example

  3. Andreas Beer
    Member
    Posted 6 years ago #

  4. Alex Rabe
    Member
    Posted 6 years ago #

    Disable in the gallery options -> slideshow "Try XHTML validation"

  5. Andreas Beer
    Member
    Posted 6 years ago #

    Oh, great. That was the trick. Thank you.

  6. cyngus
    Member
    Posted 6 years ago #

    i am having the same error only, it is being displayed on any gallery inside of a category post page,

    say the homepage shows a few posts... the gallery displays fine. but if you click on a post in the category menu

    it gives that same error..

    this only happens on certain themes.

    im sing wp 2.51 and the nextgen .96

  7. Jesq
    Member
    Posted 6 years ago #

    I'm having the same problem as cyngus. I checked to see if the code is in the <head> section and it is there. I tried installing an older version. I have double, triple and quadruple checked all of the settings in the "options" tab. I'm have spent hours and hours trying to locate the issue and it is driving me crazy. I can see the gallery fine, but the slide show will not work. Here are my server settings:

    Operating System : FreeBSD
    Server : Apache/2.2.6 (Unix) mod_ssl/2.2.6 OpenSSL/0.9.7e-p1
    Memory usage : 14.06 MByte
    MYSQL Version : 5.0.24a-log
    SQL Mode : Not set
    PHP Version : 5.2.2
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 128M
    PHP Max Upload Size : 20000000
    PHP Max Post Size : 8M
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

    Do I need to mess with the permissions on certain files? Most of them are set to 755. I'm seriously going crazy trying to get this thing to work. Thanks, Jake

  8. hunreal.com
    Member
    Posted 5 years ago #

    Same problem, but your solution did not work:

    I just upgraded to WP 2.7 and updated my Nextgen Gallery to the latest version. "The Flash Player and a browser with Javascript support are needed.." message is being displayed instead of a slideshow now.

    Alex, you suggested: Disable in the gallery options -> slideshow "Try XHTML validation"
    This was already unchecked in my settings, so I checked it and unchecked again, no change.

    Any further ideas?

    I would go back to an earlier version of Nextgen if nothing else works, but how can I without acidentally deleting or harming my galleries?

    Thanks!

  9. hunreal.com
    Member
    Posted 5 years ago #

    Here is a link with the problem:

  10. hunreal.com
    Member
    Posted 5 years ago #

  11. sebramsland
    Member
    Posted 5 years ago #

    I'm experiencing excactly the same problem, after upgrading Nextgen (and the flashviewer) to the 2.7 version of WP.

    When integrating flashviewers to my galleries, I get:
    "The Flash Player and a browser with Javascript support are needed.."

    -

    "Try XHTML validation" was already unchecked.
    Reinstalling the plugins did not work.

    I have other flash elements working on my site, so thats not the issue either.

    Example:
    http://www.sebastianramsland.com/?page_id=110

  12. Alex Rabe
    Member
    Posted 5 years ago #

    Some other plugin (flash video player) loads a older swfobjects... update or deactivate it

  13. sebramsland
    Member
    Posted 5 years ago #

    Deactivating Flash Video Player did not work.

  14. berchman
    Member
    Posted 5 years ago #

    I am also having the same issue. Slideshow will not display after updating plugin and WP.

    WP 2.7
    NGG: 1.0.1

    My site:
    http://tinyurl.com/ydyzta

    I think the issue may be in the call to the slideshow here:

    <script type="text/javascript" defer="defer">
    		var so15 = new SWFObject("http://www.mydomain.com/wp-content/plugins/nextgen-gallery/imagerotator.swf", "ngg_slideshow", "485", "280", "0", "#000000");
    		so15.addParam("wmode", "opaque");
    		so15.addVariable("file", "http://www.mydomain.com/wp-content/plugins/nextgen-gallery/nggextractXML.php?gid=");
    		so15.addVariable("linkfromdisplay", "true");
    		so15.addVariable("shownavigation", "false");
    		so15.addVariable("showicons", "true");
    		so15.addVariable("overstretch", "false");
    		so15.addVariable("backcolor", "0x000000");
    		so15.addVariable("frontcolor", "0x888888");
    		so15.addVariable("lightcolor", "0xCC0000");
    		so15.addVariable("screencolor", "0x000000");
    		so15.addVariable("rotatetime", "5");
    		so15.addVariable("transition", "random");
    		so15.addVariable("width", "485");
    		so15.addVariable("height", "280");
    		so15.write("ngg_slideshow");
    	</script>

    I see this line:
    so15.addVariable("file", "http://www.mydomain.com/wp-content/plugins/nextgen-gallery/nggextractXML.php?gid=");

    Yet there is no nggextractXML.php in the updated directory.

    Is that the issue?

    Should I switch to nextgen-flashviewer?

  15. magarciaguerra
    Member
    Posted 5 years ago #

    I had same problem. I fix it setting chmod 755
    I had to set chmod all folder:

    /wp-content/plugins/nextgen-gallery

    I works perfect now!!!
    I hope this helps

    If you want more information, my history is here:
    http://wordpress.org/support/topic/224730?replies=16

  16. ecoscope
    Member
    Posted 5 years ago #

    it works for me after adding the following to
    wp-content/plugins/nextgen-gallery/nggfunctions.php

    WP 2.7, NGG 1.0.1

    nggfunctions.php line 57:

    // create the output
    $out = "\n".'<script type="text/javascript" src="'.NGGALLERY_URLPATH.'/admin/js/swfobject.js"></script>';
    $out .= '<div class="slideshow">' . $swfobject->output() . '</div>';

  17. fun1450
    Member
    Posted 5 years ago #

    Hello

    Go to Gallery - options - Gallery
    and check "Integrate slideshow:"

    it works for me

  18. Morten Rand-Hendriksen
    Member
    Posted 5 years ago #

    @ecoscope: That script change worked for me too. Thanks a bunch! Maybe Alex should take a look at it as well?

    it works for me after adding the following to
    wp-content/plugins/nextgen-gallery/nggfunctions.php

    WP 2.7, NGG 1.0.1

    nggfunctions.php line 57:

    // create the output
    $out = "\n".'<script type="text/javascript" src="'.NGGALLERY_URLPATH.'/admin/js/swfobject.js"></script>';
    $out .= '<div class="slideshow">' . $swfobject->output() . '</div>';

  19. peterassmann
    Member
    Posted 5 years ago #

    thank you now it worked too at my site :)

  20. pjf02536
    Member
    Posted 5 years ago #

    Found the root of the issue (I was seeing too)
    wp 2.7 gallery 1.0.2

    I had wp-simpleviewer active

    The problem:
    The wp-simpleviewer plugin also has a swfobject.js file.

    The Solution(s):
    1) disable/uninstall the wp-dimpleviewer plugin
    or
    2) replace the simpleviewer swfobject.js with the one found in the nextgen-gallery/admin directory (all works fine )

    that is it, a simple file version problem where the older was being loaded in lieu of the one needed by the gallery/flashviewer

  21. KriLL3
    Member
    Posted 5 years ago #

    I got the same issue, however the fixes above don't work, and I don't have wp-simpleviewer.

    NextGEN Gallery 1.1.0
    Wordpress 2.7.1

    http://www.afot-o.se/

    anyone got any idea why this is happening?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.