WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Still the same error with Yoast's SEO sitemap (5 posts)

  1. tizz
    Member
    Posted 2 years ago #

    Conflict with SEO Yoast described here hasn't been solved in Nextgen 1.9.5. Solution is to add the following line:

    $newimage['src'] = $image->imageURL;

    just above the line:

    $this->images[$src] = $newimage;

    in /nextgen-gallery/lib/sitemap

    I thought it would be corrected in this version, so now I hope for the next. Who has the two plugins, must check the sitemap submitted to Google webmaster and redo the correction.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. tizz
    Member
    Posted 2 years ago #

    The solution above seems doesn't work no more with new version. Map has been sent 2 hours ago, now google show again 475 errors

  3. tizz
    Member
    Posted 2 years ago #

    Well, I added that line in both functions, not only add_gallery but also add_images function, and now seems to work. The general map is still pending, so it still shows the errors, but the single map now doesn't show errors no more after re-submit.
    Photocrati please, fix it in the next version.

  4. bizint
    Member
    Posted 2 years ago #

    I think I have the same situation as you....I'm still showing 118 errors "pending"....I have deleted and made changes to php, there is still something wrong for me for sure. Shame because I feel comfortable with the multiple sitemaps Yoast produces...

  5. tizz
    Member
    Posted 2 years ago #

    You don't have to delete nothing. You only have to add

    $newimage['src'] = $image->imageURL;

    above:

    $this->images[$src] = $newimage;

    in add_gallery and add_images functions, in /lib/sitemap.php, and should be work. Re-submit map and wait 'til has been sent.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic