WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Slide Show Stretch h vs Fit vs Etc (3 posts)

  1. Flirtilizer
    Member
    Posted 4 years ago #

    I love what this plugin is suppose to do. I love the galleries.

    The slide show though, its been giving me fits for a long time.

    I asked before if there is a way to make it properly display images. I'm ready to give up on it.

    Is it that I don't understand or it is the thing just busted?

    I've seen others post about pictures within the slideshow not being centered, that's part of my problem too.

    Sometimes they images display okay, sometimes they don't fit the image, sometimes it does. Yesterday I tried setting images to the size I want them and upload them, still did work. They still show up with heads chopped off and such.

    Is there no way to make this work? I don't want to keep spending time on something that's not going to work. This plugin is good enough to pay for, if I can get this fixed.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. DouglasJohnNienhuis
    Member
    Posted 4 years ago #

    Hi, Flirtilizer

    I don’t think it’s broken exactly. I’ve been dealing with the same problem, and as far as I can figure out, it just can’t do what I want it to do. There are no options in the menu that will give me proper results. The best I can do is to get the landscape images to display properly and the portrait images to display much smaller. Or I can get the portrait images to display properly, but then the landscape images are much smaller. Or, finally, I can get landscape and portrait images to display at the same size but with black bars on the sides or top and bottom of every single picture.

    I think this is how it works: There are only two settings in the options menu that affect how the image is displayed.

    1) Default size (in pixels Width X Height)
    2) Stretch Image true/false/fit/none

    As far as I can tell, you can’t leave the default size blank. I tried inputting no numbers here and I ended up with no pictures and no slide show at all. The default size is Width (W) by Height (H). This, to me, seems to be the heart of the problem. No matter what numbers you put into these boxes, it is going to screw up either your landscape or portrait images. It should have an option for “long edge” or something like that to keep all pictures the same size.

    For example, you could set the long edge to 480 pixels. In a portrait image, it would be 480 pixels high, since the height is the long edge and the width would be set proportionally. A landscape image with this same setting would be 480 pixels wide, since the width is the long edge, and the height would be set proportionally. Then it doesn’t matter whether the image is portrait or landscape. It always shows the same and shows the entire picture. However, this option doesn’t exist in NextGEN Gallery Slideshow.

    If you want black bars on just some of your images, the numbers you enter in the Default Size should be proportionally the same as the original images you uploaded. I always upload images that are 600 X 800 (long edge is always 800). That’s a ratio of 3:4. So whatever numbers I put into the Default Size have to be 3:4 or 4:3. The exact numbers you choose I guess depend on how big you want the images in your slide show to be based on your blog layout and the width of the column. The problem with this method is that some pictures will display smaller than others.

    If you want all your images to be the same size, then you should enter identical values for Width and for Height. Figure out what the maximum width of the column in your blog is (I don’t even know how to do that. I just guess.). Then enter that number for both. If your column is 500 pixels wide, you could enter a Default size of 500 X 500 or 480 X 480. Then all your images will display at exactly that size. However, the portrait images will have black bars on the side. The landscape images will have black bars on the top and bottom.

    The only other option in the menu that affects how images are displayed seems to be the “Stretch Image” option. The four settings here (true/false/fit/none) are really confusing, but in the end, it seems like only one setting is of any use at all.

    I think this is what happens with the four options (based on my tests):

    Stretch Image is “true.”
    The images aren’t stretched at all. The picture box is filled completely with the image (no black bars anywhere). But (depending on what you input for height and width) part of either the landscape or portrait is cut off. So it’s a useless setting. Who wants part of their images to be cut off?

    Stretch Image is “false.”
    Again, no images are stretched in any way. However, in this case, you see all of each picture no matter whether it is portrait or landscape (assuming, of course, that the default size you selected has the same proportions as your uploaded images). This is the only setting that does anything remotely right, so I think it is the only possible option.

    Stretch Image is “fit.”
    Images get distorted – stretched or shrunk – to fit into the picture window. And look terrible. I have no idea why anyone would ever want to do this.

    Stretch Image is “none.”
    This is the craziest setting. I have no idea what is going on with this one. When I have my default size matching a portrait image (long edge up and down), the portrait images show perfectly. They are resized to fit the picture window and the proportions are good. However, the landscape image isn’t resized at all, and all I see is a tiny portion of the image – just whatever would fit inside that window area. When I have my default size matching a landscape image (long edge going side to side), the exact opposite happens. I have no idea what is going on here. In any event, it’s a complete mess, so the “none” setting seems pointless as well.

    In theory, there are lots of possible combinations between Default size and Stretch image. However, I think only “Stretch Image is false” is of any use. So that gives only three basic options:

    Default Size Stretch Image
    3:4 false
    4:3 false
    1:1 false

    The first one makes portrait images larger whereas landscape images are smaller and have black bars on the top and bottom.

    The second one makes landscape images larger whereas the portrait images are smaller and have black bars on the sides.

    The third one makes all the pictures the same size but shows black bars on all of them.

    At the moment, I’ve settled on the 1:1 option with Stretch Image is false. Based on the width of my column in my theme, I chose 550 pixels as the right size. So it’s 550 X 550 (1:1).

    Here is an example from my blog with those settings:

    http://dougnienhuis.com/?p=1935&show=gallery

    Just click on (Show as Slideshow) to see how it looks.

    Hope this helps a little bit. Let me know if you’ve figured out any other tricks.

    Doug

  3. Flirtilizer
    Member
    Posted 4 years ago #

    Hey Douglass, wow, complicated.

    I think if the slideshow widget would just center the images that would take care of 90% of my problem. Someone posted some stylesheet coding that might work.

    I'm going to look for that.

    I would donate it if were fixed and the author might fix it if I donated but who knows. LOL

    I'm at the point of removing it now.

    It looks great on your site. Maybe I can grasp what you said later. :)

    Thanks for the help, above the call of duty too!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.