WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] Shortcode Backwards Compatibility Broken (1 post)

  1. Pertinax
    Member
    Posted 5 years ago #

    I have a severe problem with the shortcode backwards compatibility; it seems it causes crushing CPU load when NGG is upgraded to 1.0x (on 2.7 with PHP 5). Specifically, I have hundreds of galleries, comprising tens of thousands of images, all constituted using the "singlepic" shortcode.

    Normally, even a very large gallery will load within about 500ms even when the (dedicated with 4GB and very generous PHP settings) server is loaded, but with NGG 1+ these galleries take 30-100 seconds to load without any server traffic, and render the server useless when there is traffic to multiple galleries.

    I'm guessing this is a backwards compatibility issue with the shortcode or otherwise, but I have no definitive way of testing. Since I can't upgrade all the previous shortcode, is there any indication of what might be at fault, or a fix?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.