WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] Running NGG with Shadowbox - Images will open twice (3 posts)

  1. Chickow
    Member
    Posted 4 years ago #

    Hey there!
    I've got the problem using NGG with Shadowbox JS.
    If I use any NGG effect (thickbox etc.) and at the same time Shadowbox for the whole page, any image will open in JS twice, if I click on it. Once by NGG effect and once by Shadowbox JS...

    Is it possible to use Shadowbox with NGG somehow? At the moment, I've got the ngg-effect deactivated and Shadowbox works fine with the ngg-gallery, but it doesn't work with the sidebar widget?

    Anyone with a solution?

  2. rwoood
    Member
    Posted 4 years ago #

    same here with lightbox 2 for posts and NGG on sidebar ...

    it seems NGG can't proccess your post pics backward. so we have a problem unless somebody finds a solution. we would have to change all post pictures to be set up with NGG and turn off other JS afterwards. then it would work, but to be honest: I wouldn't like to make all pictures chained on NGG. What if NGG support stops. Changing all 200 posts back? No ... there MUST be another solution ...

  3. Michael Goitein
    Member
    Posted 3 years ago #

    Good to see someone else having the same issues I did.

    The way I solved it was simply by enabling Thickbox for NextGen Gallery slideshows (Gallery >> Options >> Effects.

    Both now work fine. Admittedly, we didn't resolve the Lightbox issue, but the .js craziness was getting way out of hand. Thickbox seems to have a much more compatible footprint.

    Another way to handle this is noted in this post:

    http://wordpress.org/support/topic/plugin-nextgen-gallery-lightbox-effect-with-shadowbox-js?replies=3

    Just set the automation for Shadowbox to "off" here:
    Settings>Shadowbox>Automation>images - OFF

    Hope this helps...

Topic Closed

This topic has been closed to new replies.

About this Topic