WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Resize & Thumbnail creation not working (27 posts)

  1. Guido Bouman
    Member
    Posted 2 years ago #

    I migrated a WordPress setup from a development server to a live server, and now the Thumbnail creation & image resizing aren't working.

    The plugin does not generate any errors, and the uploading of images went without any trouble.

    The gallery folder is recursively set to 777. (Not safe but I had to try something)

    Any one knows what I might be forgetting?

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. englebip
    Member
    Posted 2 years ago #

    If you go to Gallery > Overview > Plugin check (click on the button) and Server settings, do you see anything out of the ordinary? Is the GD library installed?

  3. Guido Bouman
    Member
    Posted 2 years ago #

    Plugin check:
    All fine.

    Server Settings:
    Operating System : FreeBSD (64 Bit)
    Server : Apache/2.2.14
    Memory usage : 28.73 MByte
    MYSQL Version : 5.1.42
    SQL Mode : Not set
    PHP Version : 5.2.16
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 48
    PHP Max Upload Size : 32M
    PHP Max Post Size : 32M
    PCRE Backtracking Limit : 500000
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

    Graphic Library:
    GD Version : bundled (2.0.34 compatible)
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : Yes
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : No
    XBM Support : Yes
    JIS-mapped Japanese Font Support : No

    That should work, right?

  4. TCNina
    Member
    Posted 2 years ago #

    Hi,

    I got the same problem. When I try to change a thumbnail, this small "load"-screen is loading and loading and loading and doesn't come to an end.

    The plugin-check says everything is fine.

  5. Brad Smith
    Member
    Posted 2 years ago #

    I'm getting the same thing. The thumbnail scroll bar runs but just hangs at the end without creating the thumbnail.

  6. freckleboy
    Member
    Posted 2 years ago #

    I also have the same problem. Plugin check OK. Server settings:

    Operating System : Linux (64 Bit)
    Server : Apache/2.2.20 (Unix) mod_ssl/2.2.20 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635
    Memory usage : 28.92 MByte
    MYSQL Version : 5.0.92-community
    SQL Mode : Not set
    PHP Version : 5.2.17
    PHP Safe Mode : Off
    PHP Allow URL fopen : Off
    PHP Memory Limit : 32
    PHP Max Upload Size : 2M
    PHP Max Post Size : 8M
    PCRE Backtracking Limit : 500000
    PHP Max Script Execute Time : 30s
    PHP Exif support : No
    PHP IPTC support : Yes
    PHP XML support : Yes
    Graphic Library

    GD Version : bundled (2.0.34 compatible)
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : No
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : Yes
    XBM Support : Yes
    JIS-mapped Japanese Font Support : No

    Any help appreciated.

  7. Guido Bouman
    Member
    Posted 2 years ago #

    Our memory limits are quite low, could it be that the script hits the memory limit without returning an error?

  8. Guido Bouman
    Member
    Posted 2 years ago #

    My working server:

    Plugin check:
    All fine.

    Server settings:
    Operating System : Linux (32 Bit)
    Server : Apache/2
    Memory usage : 15.93 MByte
    MYSQL Version : 5.1.58-log
    SQL Mode : Not set
    PHP Version : 5.2.17
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 128
    PHP Max Upload Size : 20M
    PHP Max Post Size : 20M
    PCRE Backtracking Limit : 500000
    PHP Max Script Execute Time : 200s
    PHP Exif support : No
    PHP IPTC support : Yes
    PHP XML support : Yes

    Graphic Library
    GD Version : bundled (2.0.34 compatible)
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : No
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : No
    XBM Support : Yes
    JIS-mapped Japanese Font Support : No

    The memory limit is 128 MB on my working server, looks like that might be the problem.

  9. freckleboy
    Member
    Posted 2 years ago #

    Upped my memory limit to 64MB due to a problem with google analytics plugin and it solved the thumbnail problem! All good.

  10. englebip
    Member
    Posted 2 years ago #

    Thanks freckleboy; my settings actually have PHP Memory Limit : 128, so that may be indeed the issue.

  11. Brad Smith
    Member
    Posted 2 years ago #

    How do I change my memory settings? Is this adjustment on my computer or the server etc?

  12. freckleboy
    Member
    Posted 2 years ago #

  13. Halvor
    Member
    Posted 2 years ago #

    Just have to tell you, Freckleboy: It worked perfect. I am NOT a programmer, so being able to get such a fix working at the first attempt is great. Thank you !!

  14. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    Additional note:

    It has been my experience also that the NextGen script(s) can 'timeout' on a busy server...especially in a shared environment...and behaves as noted above...i.e., the thumbnail creation starts, then just hangs if time exceeded. Doing just 10 or so at once fixed this for me (as opposed to 50).

    PHP Max Script Execute Time : 200s <=========exceeding this time can cause issues with NextGen! In my case, the default is 30 seconds.

  15. mikealfadelta
    Member
    Posted 2 years ago #

    Help...

    I have exactly that problem (that the memory limit has been exceeded). So no thumbs generated...

    I went through the above messages, but I can't really figure out how to get that memory limit raised.

    Is there a kind person who'd like to help?

  16. Halvor
    Member
    Posted 2 years ago #

    I changed the file 'default-constants.php : (the 128M was 64M before and the 64M was 32M before)

    // set memory limits
    if ( !defined('WP_MEMORY_LIMIT') ) {
    if( is_multisite() ) {
    define('WP_MEMORY_LIMIT', '128M');
    } else {
    define('WP_MEMORY_LIMIT', '64M');
    }
    }
    if ( ! defined( 'WP_MAX_MEMORY_LIMIT' ) ) {
    define( 'WP_MAX_MEMORY_LIMIT', '256M' );
    }

  17. Brad Smith
    Member
    Posted 2 years ago #

    My hosting company BlueHost suggested adding a php.ini file to increase memory size instead of editing the wp-config.php file. I got step-by-step instructions through chat support.

    Accomplished with a few well-written steps using the cPanel. They recommend a max memory of 128 MB.

    Perhaps this is an alternative to consider as it is button pushing oriented vs code writing/editing. Not sure if it is limited to host providers with cPanel interfaces.

  18. mikealfadelta
    Member
    Posted 2 years ago #

    But how do I do it? I've tried to figure it out (and tried some different things), but I haven't been able to do as you write below in the quotation...

    Where do I have to set in the lines you have typed?

    I changed the file 'default-constants.php : (the 128M was 64M before and the 64M was 32M before)

    // set memory limits
    if ( !defined('WP_MEMORY_LIMIT') ) {
    if( is_multisite() ) {
    define('WP_MEMORY_LIMIT', '128M');
    } else {
    define('WP_MEMORY_LIMIT', '64M');
    }
    }
    if ( ! defined( 'WP_MAX_MEMORY_LIMIT' ) ) {
    define( 'WP_MAX_MEMORY_LIMIT', '256M' );
    }

  19. Halvor
    Member
    Posted 2 years ago #

    Mike: I am not a programmer, but I'm good at 'copy and paste'. Everything is already in the file 'default-constants.php'. The section looked like this :

    // set memory limits
    if ( !defined('WP_MEMORY_LIMIT') ) {
    if( is_multisite() ) {
    define('WP_MEMORY_LIMIT', '64M');
    } else {
    define('WP_MEMORY_LIMIT', '32M');
    }
    }
    if ( ! defined( 'WP_MAX_MEMORY_LIMIT' ) ) {
    define( 'WP_MAX_MEMORY_LIMIT', '256M' );
    }

    I changed only the numbers, so the section looks like this:

    // set memory limits
    if ( !defined('WP_MEMORY_LIMIT') ) {
    if( is_multisite() ) {
    define('WP_MEMORY_LIMIT', '128M');
    } else {
    define('WP_MEMORY_LIMIT', '64M');
    }
    }
    if ( ! defined( 'WP_MAX_MEMORY_LIMIT' ) ) {
    define( 'WP_MAX_MEMORY_LIMIT', '256M' );
    }

  20. mikealfadelta
    Member
    Posted 2 years ago #

    Hmm.... I have not done the editing in the default-constants file, but the thumbnails still aren't showing? Very frustrating as the copy-paste went fine (i have doubble checked if I had done it correct...)

    Any notes on why it still isn't working?

  21. bh_WP_fan
    Member
    Posted 2 years ago #

    You can set your memory_limit to be anything you want via your default-constants.php file but if your host isn't going to allow the increase, it won't make any difference. See if your host has methods of their own where you can increase your memory_limit to 128M

  22. Halvor
    Member
    Posted 2 years ago #

    bh_WP_fan: Very true. But the change is worth a try.. (for us beginners)

  23. celiapgt
    Member
    Posted 2 years ago #

    Hello,

    I'm sorry to report this, but my bulk thumbnail resizing doesn't work. I've tried to resize one image at a time, but doesn't work either. Folder's permisions are set to 777. It seems like a bug, because previous version woked perfectly in this area.

    Please, advise.

    My server settings are:
    Operating System : Linux (64 Bit)
    Server : Apache
    Memory usage : 33.5 MByte
    MYSQL Version : 5.1.59
    SQL Mode : Not set
    PHP Version : 5.3.3
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 86
    PHP Max Upload Size : 50M
    PHP Max Post Size : 100M
    PCRE Backtracking Limit : 500000
    PHP Max Script Execute Time : 7s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

    Graphic Library

    GD Version : bundled (2.0.34 compatible)
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : No
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPEG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : Yes
    XBM Support : Yes
    JIS-mapped Japanese Font Support : No

    And after checking my NextGen plugin, these are my results:

    Check plugin/theme conflict

    No conflict could be detected
    ok Test image function

    Could create image with 3264 x 2448 pixel
    ok Check theme compatibility

    Your theme should work fine with NextGEN Gallery

  24. celiapgt
    Member
    Posted 2 years ago #

    Forgot to say that cannot change PHP limit, becuase it's set by host provider.

  25. Guido Bouman
    Member
    Posted 2 years ago #

    Try to contact your hoster, your script execution time is way too low for any processing script. (PHP Max Script Execute Time : 7s) It should be at least 30 seconds, preferably 60 or 120 seconds.

  26. TCNina
    Member
    Posted 2 years ago #

    I changed the file 'default-constants.php :

    Ok, and where is this file usually saved? Which folder? I'm locked in my ftp and looking around, but can't find it.

    Btw.: I've contacted my host and got the answer, memory limit is 128. So I should be able to set it in anything lower.

  27. TCNina
    Member
    Posted 2 years ago #

    Found the file and changed the Mem-limit, but if I check now via Gallery > Overview > Plugin check it still says "PHP Memory Limit 72". I get tired. -.-

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.