WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: NextGEN Gallery] Receiving "Invalid upload. Error Code : 6" when trying to upload images (9 posts)

  1. jimmyink
    Member
    Posted 4 years ago #

    After updating WordPress to 2.9.2, I tried to upload some images to a newly created gallery and received "Invalid upload. Error Code : 6" for each image that I tried to upload. I rolled back WP to 2.9.1 and reinstalled Nextgen Gallery with no luck.

    I cannot seem to find any documentation as to what Error Code 6 is or what is causing this.

    Here's my Settings.

    Server Settings
    * Operating System : FreeBSD (32 Bit)
    * Server : Apache/1.3.41 (Unix) FrontPage/5.0.2.2635 mod_ssl/2.8.31 OpenSSL/0.9.7m
    * Memory usage : 12.66 MByte
    * MYSQL Version : 4.1.22
    * SQL Mode : Not set
    * PHP Version : 5.2.11
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 32M
    * PHP Max Upload Size : 2M
    * PHP Max Post Size : 8M
    * PHP Output Buffer Size : N/A
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    Graphics Library
    * GD Version : bundled (2.0.34 compatible)
    * FreeType Support : Yes
    * FreeType Linkage : with freetype
    * T1Lib Support : Yes
    * GIF Read Support : Yes
    * GIF Create Support : Yes
    * JPG Support : Yes
    * PNG Support : Yes
    * WBMP Support : Yes
    * XPM Support : No
    * XBM Support : Yes
    * JIS-mapped Japanese Font Support : Yes

    Any Ideas? Thanks in advance.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. jimmyink
    Member
    Posted 4 years ago #

    Surely someone knows...

  3. jimmyink
    Member
    Posted 4 years ago #

    Oh, and disabling the Flash uploader does not solve the problem.

  4. jimmyink
    Member
    Posted 4 years ago #

    Surprisingly downgrading my PHP version from 5.2.11 to 4.4.7 gets it working again. I don't consider this to be a fix, I even get a message from NGG to upgrade so I count this as resolved just yet. I can't be the only person (out of 1.5 million) that has come across this.

    Anyone? Please, I'm stating to look a little crazy just posting to myself.

  5. Alex Rabe
    Member
    Posted 4 years ago #

    Post the settings under PHP4 to compare them with the PHP5 values

  6. jimmyink
    Member
    Posted 4 years ago #

    ----Working----
    * Operating System : FreeBSD (32 Bit)
    * Server : Apache/1.3.41 (Unix) FrontPage/5.0.2.2635 mod_ssl/2.8.31 OpenSSL/0.9.7m
    * Memory usage : 12.6 MByte
    * MYSQL Version : 4.1.22
    * SQL Mode : Not set
    * PHP Version : 4.4.7
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 32M
    * PHP Max Upload Size : 2M
    * PHP Max Post Size : 8M
    * PHP Output Buffer Size : N/A
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    ----Not Working----
    Server Settings
    * Operating System : FreeBSD (32 Bit)
    * Server : Apache/1.3.41 (Unix) FrontPage/5.0.2.2635 mod_ssl/2.8.31 OpenSSL/0.9.7m
    * Memory usage : 12.66 MByte
    * MYSQL Version : 4.1.22
    * SQL Mode : Not set
    * PHP Version : 5.2.11
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 32M
    * PHP Max Upload Size : 2M
    * PHP Max Post Size : 8M
    * PHP Output Buffer Size : N/A
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

  7. Alex Rabe
    Member
    Posted 4 years ago #

    No differences, so it must be a server setup issue. Can you upload images with the wordpress core media lib ?

  8. jimmyink
    Member
    Posted 4 years ago #

    You're a clever cookie alex.

    Checked the core media library and that's not working either. After a bit of research I think I've narrowed it down to the temp folder not being defined in 'php.ini'. I've sent a request to my hosting company to fix it as my control panel access doesn't give me allow me. So now I play the waiting game.

    I'll post the outcome when I finally get this resolved.

  9. jimmyink
    Member
    Posted 4 years ago #

    OK, it's fixed.

    Turns out there was no temp folder assigned in the php.ini file.

    Found the solution here - Link

    You may need to get you hosting provider to do this for you as some control panels will not give you enough access to the server.

    Thanks again for your help Alex. Are you still looking for a new icon for NGG?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.