WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] [Plugin: NextGen Gallery] Slideshow widget won't load pictures (19 posts)

  1. jockoe
    Member
    Posted 5 years ago #

    The widget that adds a slideshow isn't loading the pictures in browsers other than IE7. I've deactivated, deleted, re-installed NextGen, but that didn't fix the problem. (I said it did in another post, but I misspoke) Any idea what might be the problem?

  2. aenorsex
    Member
    Posted 5 years ago #

  3. plovs
    Member
    Posted 5 years ago #

    To be abe to use slideshow on nextgen you must install imagerotator.swf. Then you must point nextgen to the location of that file using: Gallery-Options and then on the right side of the page Slideshow.

  4. jockoe
    Member
    Posted 5 years ago #

    I am using imagerotator.swf. The widget works fine in IE7. It's on FireFox and Safari that it won't load. You can see it at my site...
    http://www.tracyandcarol.com/

  5. ecacarva
    Member
    Posted 5 years ago #

    Jockoe

    I instaled nextgen 1.3.3 and after 1.3.2 and with a simple post page the slide show does not works, did you have any tip for me?

    ps: The list images works

    Tks

  6. jockoe
    Member
    Posted 5 years ago #

    I am having problems with NextGen myself. One thing that I recently did to fix a plugin seemed to clear up most of my problems with all of my plugins. It may not even apply to your question, but here is what I did...

    2 part solution...

    1. In your Dashboard... Settings > General I made sure "www" was part of the Blog address (URL) (It was already there for me)

    2. Using phpMyAdmin... I logged into my WP database > go to 'wp_options' > browse > find 'siteurl' > added the "www" to the siteurl

    After doing this most every plugin problem I had disappeared.

  7. percentjuice
    Member
    Posted 5 years ago #

    same issue. see examples below.

    code I am using:
    <div id="slideShow"><?php { nggSlideshowWidget(1,750,259); }?></div>

    my site: http://percentjuice.com/
    fresh install w default theme: http://percentjuice.com/testWP/

  8. theKiwi
    Member
    Posted 5 years ago #

    What I have discovered is that if I have the Permalink set to "default", then the slideshow works.

    If the permalink is set to "Day and name" then the slide show doesn't work.

    Does anyone else see this?

    Does it work with the permalink set to "Day and name" for anyone else?

    Roger

  9. percentjuice
    Member
    Posted 5 years ago #

    my Gallery permalink option reads:

    "Activate permalinks: When you activate this option, you need to update your permalink structure one time."

    Neither checking nor unchecking that option affects the issue. I do not see a "Day and name" sub-option. My Gallery/Options/Slideshow tab is curiously blank(!).

    The error that has been coming up for me is from nggwidget:
    '<a href="http://www.macromedia.com/go/getflashplayer">Get the Flash Player</a> to see the slideshow.</div>'
    updating swfobject.js has no effect.

    IE6 shows an additional JS error:
    "'J.parentNode' is null or not an object"

  10. percentjuice
    Member
    Posted 5 years ago #

    am using version 1.2.1 while this is sorted out. others can find said working version here:
    http://wordpress.org/extend/plugins/nextgen-gallery/download/

  11. zzb
    Member
    Posted 5 years ago #

    If you want to revert back to 2.7.1 here is the link for past revisions.

    http://wordpress.org/download/release-archive/

  12. jockoe
    Member
    Posted 5 years ago #

    I downgraded to 1.2.1 also, but that did not fix the problem. (I re-upgraded to 1.3.3). I set permalinks to default, and every other option. Checked/Unchecked "Activate permalinks: When you activate this option, you need to update your permalink structure one time." in Gallery > Options.

    The "Day and Time" permalinks is not under "Gallery". It is a WP option you'll find under Settings > Permalinks.

    I was having this problem with version 2.7.1 also. I was hoping 2.8 would make it go away.

    I'm out of ideas.

  13. percentjuice
    Member
    Posted 5 years ago #

    I was rebuilt my new WP install and got everything working there. Am narrowing down the conflict. It seems to relate to the DB. Multiple installs of this plug-in can create an irreparable DB. (Solution-wise, I'm still stuck. I've wiped the old tables and imported the working ones without effect. May have to rebuild WP.)

  14. jockoe
    Member
    Posted 5 years ago #

    I'm not so sure I'd want to go that far to get it working. Please post if you're successful or not.

  15. percentjuice
    Member
    Posted 5 years ago #

    my last broken version was erroring when making this call:
    http://yourdomain.com/wp-content/plugins/nextgen-gallery/xml/imagerotator.php?gid=1&31 (those last two numbers will vary.) Safari was logging the error in its Activity window.

    one of my fresh installs worked. [there were multiple unintentional reinstalls due to mistakenly having left the Fantastico window open. every time I reopened my browser, I reinstalled all of WP. yay.]

  16. theKiwi
    Member
    Posted 5 years ago #

    OK - by some miracle I seem to have managed to fix this.

    What I did was delete the path to imagerotator.swf that was in the Next-Gen settings

    blog/wp-content/imagerotator.swf

    and then click the button to have it found. It came up with this

    http://lisaandroger.com/blog/wp-content/imagerotator.swf

    so I saved that, and lo and behold now the slideshow is working while I have a permalink structure (set in the Word Press options) of "Day Month", so a link to a page running a slideshow now is for example

    http://lisaandroger.com/nggallery/post/photogallery-of-the-deer-island-trip/slideshow/

    Does this help anyone else?

    Roger

  17. jockoe
    Member
    Posted 5 years ago #

    My imagerotator file was already set to "http://.../imagerotator.swf". I did try deleting the file and re-installing it. That did not help.

    This problem is driving me nuts.

  18. Michael Visser
    Member
    Posted 5 years ago #

    Hey people, I spent 3 hours this afternoon working to resolve this error affecting NextGEN Gallery's slideshow widget, and I did it! It's a permission issue that was masked by Permalinks being turned on, here's the link to my tutorial and step-by-step instructions.

    Link to Fix for NextGEN Gallery slideshow and WordPress 2.8

  19. mbenter
    Member
    Posted 4 years ago #

    Roger's suggestion worked for me. I deleted the path to Imagerotator, which had www in address, saved the changes to the page, then after refresh clicked on search now button. The path it found to .swf file did not include www in the address. Once I save those changes, wala, slideshow loaded and worked. BTW, I use custom permalinks and really hate changing anything with that parameter because it can really screw things up. Maybe the difference was saving the page between deleting and searching for new path. Anyway, I'm happy, this has been a maddening issue. Thanks Roger.

Topic Closed

This topic has been closed to new replies.

About this Topic