WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] Pages marked as "private" won't link to album (6 posts)

  1. jockoe
    Member
    Posted 4 years ago #

    It'll be easiest just to describe my situation... I have a "Photo Album" page at http://www.tracyandcarol.com/the_tracy_times/photo-album/. Currently it has 2 gallery listed on it. The galleries are linked to pages that are marked as "private pages". When you click on the thumbnail to see the gallery you get a "Page Not Found", though the url is correct in the address bar.

    This doesn't happen 100% of the time, but happens over 1/2 of the time.

  2. jockoe
    Member
    Posted 4 years ago #

    I disabled the permalinks option and I also had to disable the option that says "Deactivate gallery page link:". Now it's working. This is not desirable though because now the gallery page does not have its page title or captions under each thumbnail.

  3. jockoe
    Member
    Posted 4 years ago #

    I forgot to add... I'm only getting the problem with IE7 and not in FF 3.0.

  4. jockoe
    Member
    Posted 4 years ago #

    I just unchecked "private" from my gallery pages and now I can click the thumbnail on my Photo Album" page and be taken to each gallery. So the problem occurs if I mark the gallery page as "private". Does anybody know of a fix for this?

  5. gplasky
    Member
    Posted 4 years ago #

    You're not the only one. I've disabled both options you've mentioned for the time being until the issue is addressed (there's a thread around here somewhere where alex acknowledges the issue).

    I did a little hack for my gallery where I have album pages with galleries listed therein, and when clicking a gallery link, it takes you to a piclens slideshow on top of the parent album page instead of linking elsewhere.

  6. jockoe
    Member
    Posted 4 years ago #

    The theme I use made this an easy fix for me. So easy, I feel silly posting this. I use the "Atahualpa" theme. In the theme options I just need to specify the page id's of the pages I want to exclude from being shown on the menu bar. It was the perfect fix for me... I did not need to mess with the code, pages do not need to be marked "private", I don't have the word "Private:" prefixing each page, and the pages still show up in my site map.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.