WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Page jumps to the top (in the background) when opening a picture in front (5 posts)

  1. ralfhamester
    Member
    Posted 4 years ago #

    Hi,

    usually when opening a picture in NGG, it used to open in the foreground (with chosen effect, e.g. faded page in the background). When closing the picture, the page would be shown at the same position as before opening the picture.

    However, when opening a picture, it opens as expected in the foreground, but at the same time, the article in the background jumps to the top of the page. This is annoying, since the user has to scroll down again to the part of the page he/she has been reading before opening the picture.

    I am using NGG 1.5.5 with Avenue Dialogue Theme and WP 3.0 , but the bug has been there before upgrading to WP 3.0.

    Thank you.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. thedrewseum
    Member
    Posted 4 years ago #

    This is driving me crazy as well, it's a pretty huge problem on my site because I have upwards of 40 galleries on some pages.

    Seems to only be happening in Firefox. There has to be a fix for this! Someone please?

  3. thedrewseum
    Member
    Posted 4 years ago #

    Someone posted a solution here!

    http://wordpress.org/support/topic/359985

    Works for me! :)

  4. daubsi
    Member
    Posted 4 years ago #

    That's great! Thanks a lot!

  5. mfieldhouse
    Member
    Posted 3 years ago #

    Here's a way to fix it without deleting any code, just changing a few settings. This will also give you a light box with a close button which I think is easier to use.

    1. Download the JW image rotator. Upload the imagerotator folder to your web server.

    2. In the WordPress admin go to Gallery > Options > Slideshow. Configure the path to the imagerotator.swf. For example: http://www.plansforextensions.com/imagerotator/imagerotator.swf

    Click save changes

    3. Go to Gallery > Options > Effects. Change JavaScript Thumbnail effect: to 'Thickbox'. Save changes.

    4. The problem is now fixed and you have a nicer lightbox :)

    5. Some extra text may appear before your thumbnails, something like - [show in slideshow]. To remove this, go to Gallery > Options > Gallery. Remove all text in the first box next to 'Integrate Slideshow'.

    6. Excellent!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.