WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Optimizer
JW-player does not work in slideshows? (9 posts)

  1. Erik
    Member
    Posted 1 year ago #

    Just bought the premium version.
    When nextgen-gallery-optimizer plugin is activated clicking on thumbnails works great, but the slideshow with JW-player does not work. The following text is displayed "The Flash Player and a browser with Javascript support are needed."

    When deactivating the plugin, the slideshow with JW-player works without any problems. Using [nggallery id=x]

    Check here, with plugin activated: http://franzens.nu/2012/10/14/test/

    My path to JW-player is /wp-content/imagerotator/imagerotator.swf

    What can my problem be?

    http://wordpress.org/extend/plugins/nextgen-gallery-optimizer/

  2. Mark Jeldi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Erik,

    Thanks for downloading NextGEN Gallery Optimizer Premium!

    I'm not sure why there was an issue with JW-player integration...perhaps you weren't using the full file path? eg. http://sitename.com/wp-content/imagerotator/imagerotator.swf (re: Optimizer's FAQ).

    I can see you're using the WidgetKit Slideshow from YooTheme now...which seems to be working well with Optimizer and Fancybox. It looks better than JW too (minus all the branding).

    Let me know if there's anything else.

    Cheers,
    Mark.

  3. Erik
    Member
    Posted 1 year ago #

    Well, it works when the plugin is deactivated, so it should not depend on the full path problem?

    I also tested with full path, and it does not work. (It works when I disable the optimizer plugin).

  4. Mark Jeldi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Erik,

    Thanks for your reply!

    Apologies for any confusion, I thought you were referring to the slideshow slider on your test page rather than the "Slideshow" text link page.

    I've had another look and I believe the issue you're experiencing is caused by the "Activate permalinks" option at Gallery --> Options --> General Options. It looks as though you've got this switched on, as it's changing NextGEN's URL structure for things such as your "Slideshow" and "Thumbnails" links.

    I've coded Optimizer Premium to look for NextGEN's default URL structure, which appends query string parameters to much of the navigation (eg /?show=slide and /?show=gallery). With "Activate permalinks" switched on, these parameters are no longer present, which results in Optimizer not recognizing where to add the necessary scripts for either slideshow and lightbox functionality. NextGEN has no problem with this as it loads every possible script on every page of your site regardless of whether it's being used or not.

    I'm still working on a way of targeting these custom URLs, and hope to have a solution in a future version of the plugin, but for now, correcting the issue is as simple as navigating to Gallery --> Options --> General Options, switching off the "Activate permalinks" setting and clicking "Save Changes" at the bottom.

    Note: I recommend making a backup of your entire wp-content/gallery folder beforehand if you have a lot of images.

    Hope this helps!

    Cheers,
    Mark.

  5. Erik
    Member
    Posted 1 year ago #

    I am sorry to say that it did not work :(

  6. Mark Jeldi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Erik,

    That's a shame, but not to worry. That change was definitely necessary.

    I've been testing your source code with Optimizer switched on, and I've got your JW Image Rotator working locally simply by adding in the native WordPress swfobject.js file that the player requires.

    Optimizer does this automatically, but I believe there may be a conflict with the flash-based WP-Cumulus plugin you're using for your tag cloud (which hasn't been updated in over two years). It appears to be deregistering the up-to-date swfobject.js file (version 2.2) called by Optimizer, and inserting its own older file (version 1.4), which isn't compatible with JW.

    If you could try deactivating the WP-Cumulus plugin for me, that would be great! If that is indeed the source of the conflict, it would only require a minor edit to bring it up to date.

    Let me know how you go...

    Cheers,
    Mark.

  7. Erik
    Member
    Posted 1 year ago #

    I am amazed over your efforts to this detailed support :)

    WP-Cumulus is now deactivated and it is still not working. The hunt is still going on... :)

    Same status: If I deactivate the optimizer plugin, JW-player works

  8. Mark Jeldi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Erik,

    No worries. I'm happy to help...especially if I'm able to improve Optimizer in some way.

    I've managed to get hold of the Yoo Expo theme (latest version 5.5.15) you're using for testing on my development environment, and I'm afraid the issue is definitely a conflict with the theme itself. I'm seeing the same behavior as on your site...the trouble is, I've no idea what's causing it.

    I'm running in debug mode, and the theme (with or without any active plugins) is producing a load of error messages, including functions that have been deprecated since WordPress 2.0!...so there's bound to be trouble. It was originally written in 2010, so I guess development hasn't kept up with the updates.

    Are you particularly attached to this theme, at all? I'm just asking, as you may have trouble with other plugins down the track also. If you want to test compatibility for yourself, you can try briefly switching to either the default Twenty Ten or Twenty Eleven themes, where JW should load as expected.

    I'll continue looking into this...but considering all the errors in the theme, it could be anything.

    Cheers,
    Mark.

    PS. If you want to see the error notices, simply pop define('WP_DEBUG', true); into your wp-config.php file.

  9. Erik
    Member
    Posted 1 year ago #

    Okay, I see. Many thanks for your extraordinary help! I will look into this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic