WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Optimizer
[resolved] Failure to create thumbnails (2 posts)

  1. jpistori
    Member
    Posted 1 year ago #

    HI, for some reason when I try to upload images it always fails to create thumbnail.

    http://wordpress.org/extend/plugins/nextgen-gallery-optimizer/

  2. Mark Jeldi
    Member
    Plugin Author

    Posted 1 year ago #

    Hi jpistori,

    This would be an issue with NextGEN Gallery and/or your server setup. Here are four causes for thumbnail failure I've personally experienced in the past (on both shared and dedicated hosting)...

    1. Ensure php safe mode is disabled (you may need to ask your host)

    2. Ensure PHP's GD library is included and activated on your server (required for image resizing). You can test this by uploading an image through the WordPress core image uploader, as it also uses the GD library to create its small/medium/large thumbs.

    3. Ensure you have enough memory allocated to PHP (usually set in php.ini, again ask your host). You can test this by uploading a jpg image with really small dimensions (say slightly larger than the thumbnails you want created). Memory requirements increase exponentially the larger the width and height of your source image.

    4. Lastly, you'll need to check your file ownership and permissions for the entire wp-content/gallery/ folder. 775 usually works well if you're having issues (it includes everything except write access for world). This codex page might be of assistance.

    Hope this helps!

    Cheers,
    Mark.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.