WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Optimizer
[resolved] Albums/Slideshow not working on Pages in Premium version (7 posts)

  1. Laracy17
    Member
    Posted 2 years ago #

    Hi Mark,

    I paid for the premium version as I wanted it to work for all the NextGEN shortcodes but I have run into difficulties.

    The plugin works for posts but not on pages where album id is used.
    For instance, I have an album made up of 5 galleries. I click on one of the galleries and it takes me to the page, displaying all the images for the gallery. However, when I select an image it links to the image url rather than launching the fancybox effect.

    Also, when I select the Slideshow option, the wheel turns but nothing happens. I tried your suggestion of checking the thumbnails in the galleries, but they are all displayed. I have rebuilt the thumbnails in the hope that this would fix the problem but it has not.

    I disabled your plugin, then tried the Slideshow and it worked.

    So... any suggestions to make your plugin work on Pages for albums and also the Slideshow?

    Thanks :-)

    http://wordpress.org/extend/plugins/nextgen-gallery-optimizer/

  2. Mark Jeldi
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Laracy17,

    Thanks for downloading NextGEN Gallery Optimizer Premium!

    I've been doing some testing, and I'm afraid I'm struggling to recreate the issue you're experiencing. Both Fancybox and the slideshow are working perfectly on Pages for the [album id=x], [album id=x template=compact] and [album id=x template=extend] shortcodes on my end.

    Would you be able to provide a link at all?
    (Here's my email if you'd prefer it not be made public.)

    It sounds like another plugin (or your theme) is loading a conflicting script...and only on pages. Might there be a hard-coded jQuery include in your theme? I see that quite often. Loading jQuery twice on one page breaks things pretty reliably.

    Cheers,
    Mark.

    PS. I just discovered that NextGEN's slideshow breaks (loading wheel) if there's only 1 image in a gallery. Might be something to check.

  3. Laracy17
    Member
    Posted 2 years ago #

    Hi Mark,

    I sent you an email with some examples of the problems I'm encountering.

    Also, all my galleries have more than one photo in them.

    Thanks.

  4. Mark Jeldi
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Laracy17,

    Thanks for your detailed email!

    I believe the issue you're experiencing is caused by the "Activate permalinks" option at Gallery --> Options --> General Options. It looks as though you've got this switched on, as it's changing NextGEN's URL structure for things such as the "Show as slideshow" and "Show picture list" links, as well as navigation through your Album pages.

    I've coded Optimizer Premium to look for NextGEN's default URL structure, which appends query string parameters to much of the navigation. With "Activate permalinks" switched on, these parameters are no longer present, which results in the plugin not recognizing where to add the necessary scripts for both Fancybox and slideshow functionality.

    Here's an example from my testing environment:

    Default album gallery / show as slideshow link / show picture list links:
    http://sitename.tld/pagename/?album=1&gallery=1
    http://sitename.tld/pagename/?album=1&gallery=1&show=slide
    http://sitename.tld/pagename/?album=1&gallery=1&show=gallery

    Custom album gallery / show as slideshow link / show picture list links:
    http://sitename.tld/pagename/nggallery/albumname/galleryname/
    http://sitename.tld/pagename/nggallery/albumname/galleryname/slideshow/
    http://sitename.tld/pagename/nggallery/albumname/galleryname/images/

    The fix:
    I'll have to find a way of targeting these custom URLs in a future version of the plugin, but for now, correcting the issue is as simple as navigating to Gallery --> Options --> General Options, switching off the "Activate permalinks" setting and clicking "Save Changes".

    Note: I STRONGLY advise making a backup of your entire wp-content/gallery folder just in case...I lost all my images after testing the "Create new URL friendly image slugs" button below it. You won't need to use that button, but it's still good to have a backup.

    Hope this helps!

    Cheers,
    Mark.

  5. Laracy17
    Member
    Posted 2 years ago #

    Hi Mark,

    I would never have guessed the solution in a million years! Thanks for solving this for me (and for anyone else who may have encountered this issue). I am no longer cursing NextGEN or your plugin ;-)

    Much appreciated! Now, slightly off-topic from this issue:

    Is there a way to use the other features of Fancybox such as showing thumbnails below the displayed image, rather than the user clicking the left or right directional arrows?

    Cheers.

  6. Laracy17
    Member
    Posted 2 years ago #

    Actually I will mark this topic as resolved and start a new thread.

    Thanks :-)

  7. Mark Jeldi
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Laracy17,

    That's fantastic to hear! I'm glad I could help.

    Many thanks for bringing this issue to my attention, and also for the clarity and detail in your posts. This is a really useful topic, and one I know I'll be referring to myself.

    Cheers,
    Mark.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic