WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: NextGEN Gallery] Not creating Galleries (2 posts)

  1. fingmachine
    Member
    Posted 4 years ago #

    Trouble creating galleries.
    Most current software versions.

    I followed the advice in a previous post. Uninstalled and Reinstalled plug-in and got full functionality but, of course, lost all my site's images.

    I was then able to create a previously titled gallery (still on server) and click 'scan folder for new images' which fills the gallery.
    Though it would be laborious, this is not a solution due to the image numbers.

    ---

    The gallery creation problem has to do with info in the SQL files.

    With a fully functional plug-in, I imported my old ngg_ tables and lost ability to create galleries.

    I tried refreshing the plug-in and creating 5 test galleries, then exporting the ngg_ tables, then importing the files. All works fine.

    BUT when I import my old tables with all the data I lose the ability to create Galleries, even though the import works fine and completely restores the site.

    Can anyone help me figure out why this is happening, please?

    (btw: I have successfully moved dozens of sites with NGG from WPMU to standalone without this issue. The gallery creation problem only occurred on two sites. I'm determined to restore this site by editing this SQL 'til it works.)

  2. fingmachine
    Member
    Posted 4 years ago #

    Found the issue and fixed it.

    Cannot create Galleries was caused by incompatible database files.

    Solution was to:

    • Uninstall newest version. (deleting all ngg_ tables)
    • Install older version 0.99.1
    • Import backed up .sql
    • Test gallery creation - :) yay!
    • Upgrade to newest NextGen version (1.2.1)
    • Admin interface presents - 'Database Upgrade'

    Everything is back in order. Good Grief. Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.