WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Migrated NextGen, but can't create new galleries (2 posts)

  1. artfool
    Member
    Posted 1 year ago #

    I have been migrating my blog from a MySQL4 database to an updated MySQL5, and it seemed everything was going smoothly. I was able to copy my ngg tables over successfully, all the galleries, images and thumbnails showed up fine on the new blog.

    The problem is I can't create any new galleries, or edit existing ones. For instance, if I create a new gallery, it seemingly goes through all the motions, no error messages, but once it refreshes the new gallery does not show up. Odd thing is, it will successfully create the folder for the gallery in wp-content/gallery/ but it does not acknowledge the gallery in the database. I've set permissions correctly in both the plugin and the gallery folder.

    I then tried adding a new image to an existing gallery folder via FTP to see if it would show up after hitting "Scan Folder for new images". Nothing. While the existing image and thumbnail are acknowledged, the new image is not added to the gallery.

    Is there some setting in the PHP tables that I might need to change? Some permission or version conflict that would cause this? I am able to do everything else just fine with the blog, new posts, plugins, everything else works smoothly. Thanks for any help!

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. artfool
    Member
    Posted 1 year ago #

    Ha, nevermind, got it working. I disabled the plugin then exported all the databases again just to be safe. Deleted them, then enabled the plugin again so that it would rebuild the databases from scratch. Then I went into the new databases and imported everything into the newly created ones, and now it can write new galleries again. Whew.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic