WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Link Captions (8 posts)

  1. Cecelia
    Member
    Posted 3 years ago #

    I have been trying to find a way to create an image gallery with captions that can link to external pages for a gift guide on my site. I don't believe there is a way to do with with the WP gallery so I installed NexGEN hoping it has this capability.

    No luck so far. :( Can anyone advise on whether this is possible and, if so, how it can be accomplished. By knowledge of HTML, CSS or any other acronyms associated with web creation are limited.

    Thank you!

  2. thedrewseum
    Member
    Posted 3 years ago #

    I haven't had any problems putting an external link in a photo's description/caption using html.

  3. agylardi
    Member
    Posted 3 years ago #

    I have similar problem. I couldn't successfully create a link within the caption. I'm using the NextGEN for portfolio. The linked links always become like this :

    http://www.mysite.com/portfolio/\"http://www.anothersite.com/"\

    in the description of the images I just simply using "a" HTML tag. and the source for the link is "http://www.anothersite.com/". But It won't work. I don't know what's wrong.

    BTW, I'm using NextGen GalleryView add on, but I think there is no problem related to link creating with the add on.

    Is there anyone who knows anything related to the problems ?

    Thanks.

  4. whatmedia
    Member
    Posted 3 years ago #

    I am getting the same problem. I thought that I had fixed it before, but not sure what is happening now. The only thing I did was changed the formatting of the caption text to be H6.

    Any ideas?

  5. Toshi Yoshida
    Member
    Posted 3 years ago #

    The gallery edit page has a column labeled "Alt & Title Text / Description" That column has two input boxes for each image in the gallery.

    The first input box is a single line high and does not appear to like html. In my test it truncated data when it found a double quote and replacing the double with single quotes causes the html to be displayed as text rather than interpreted.

    The second multi line box with scroll bars works fine with html.

    Unless there's some special code/character that says 'what follows is html' it seems to me that you can not use html in the single line input box (which I woud call the caption box).

    If any of the people above have got html working in the signle line box I've love to see an example to tailor for my own use.

  6. Doomsan
    Member
    Posted 3 years ago #

    I have the exact same problem. Anyone knows how to fix this?. Thanks!.

  7. Doomsan
    Member
    Posted 3 years ago #

    I got around to it by modifyng the line #146 on the GalleryView plugin. I put this:

    $out .= " <span class=\"panel-overlay\"> " . "<h2>" . $picture["title"] . "</h2>". "<p>". "". Detalles . "". "</p>". "</span>";

    Hope it helps someone.

  8. gurris
    Member
    Posted 2 years ago #

    @ Doomsan I´m not sure I understand that page you had edit !
    I think you mean: nextgen-gallery/view/
    but which file ?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.