WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Issue with thumbnails (3 posts)

  1. christian70
    Member
    Posted 2 years ago #

    HI. thanx for the plugin, it's fantastic (or it is expected to be). it works perfectly in appearance (i can load pictures, thumbnail are phisically created in their folder, and it's properly integrated with monoslideshow that i use for galleries to show). but i can't manage with thumbnails: some disapperead from manager gallery window (althoug i see them in the folder), and when i try to use them in a post these warnings appears:
    ''Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions in xxx\wp-content\plugins\nextgen-gallery\lib\gd.thumbnail.inc.php on line 555''
    ''Warning: imagecopyresampled(): supplied argument is not a valid Image resource in xxx\wp-content\plugins\nextgen-gallery\lib\gd.thumbnail.inc.php on line 940'' ...
    i red so much on old topics but nothing seems to fix that. any idea would be pleased. thanks.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. micharo
    Member
    Posted 2 years ago #

    Hi, I have very similar problems!

    Help appreciated!

    Warning: imagecreatetruecolor() [function.imagecreatetruecolor]: Invalid image dimensions in xxxx/wp-includes/media.php on line 1025

    Warning: imagecopyresampled() expects parameter 1 to be resource, boolean given in xxxx/wp-includes/media.php on line 435

    Warning: imagejpeg() expects parameter 1 to be resource, boolean given in xxxx/wp-includes/media.php on line 467
    607

  3. capodieci
    Member
    Posted 1 year ago #

    I have thumbnails generation problem using with WordPress 3.5 and NextGen Gallery 1.9.9

    I have a WPMU installation (I manage many websites with a single wordpress installation) and I have thumbnail generation problem only in some websites. I did try to deactivate all the plugins, but the problem persists. The only thing that changes from one website to the other is the theme, and I did try to switch the theme with the standard theme, but no difference.

    The only problem that affect all the websites is the visualization of an image using
    websiteexample.com/wp-content/plugins/nextgen-gallery/nggshow.php?pid=3&width=350&height=350
    as this return a broken image. This affects, for example the possibility to edit a thumbnail (as the image on the left, in the dialog, does not appears). I did extensive search, but I found no solution.

    Regarding the generation of the thumbnails I get the error "A failure occurred" and pressing on "more" i read "Error: Create image failed. Check Safe Mode settings". It cannot be the safe mode, as php.ini affects all the websites, and not just some. I searched about this, but found nothing.

    Looking at the error logs of my web server I found this:
    ''Warning: imagecreatetruecolor(): Invalid image dimensions in xxx\wp-content\plugins\nextgen-gallery\lib\gd.thumbnail.inc.php on line 555'' and ''Warning: imagecopyresampled(): supplied argument is not a valid Image resource in xxx\wp-content\plugins\nextgen-gallery\lib\gd.thumbnail.inc.php on line 940''

    Anyone has some idea on how to solve this problem?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic