WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Important announcement - one time please (27 posts)

  1. jjcheno
    Member
    Posted 1 year ago #

    please make the notification "We're happy to announce Photocrati has acquired NextGEN Gallery" one time only, or at least only once per session.

    the thing pops up in my face on every page load

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. JeremyKerr
    Member
    Posted 1 year ago #

    Hey jjcheno...

    I had a similar issue when I first installed the plugin. The announcement took over the top left hand corner of every page. The dismiss button didn't work either.

    If you are comfortable with commenting out a line in the plugin code you can do the following:

    Go to Plugins > Editor and choose NextGen Gallery.

    Pick the nextgen-gallery/nggallery.php as the one to edit.

    Look for the following:

    // Display "Photocrati Acquisition Announcement"
    add_action('admin_init', array(&$this, 'display_update_notice'));

    and comment out the add_action line like this

    // add_action('admin_init', array(&$this, 'display_update_notice'));

    That got rid of the announcement things. They don't pop up anymore.

    Hope this helps!

    Jeremy

  3. jjcheno
    Member
    Posted 1 year ago #

    Thanks Jeremy, worked perfectly!

  4. JeremyKerr
    Member
    Posted 1 year ago #

    No prob! Glad I could help.

  5. studioactiv8
    Member
    Posted 1 year ago #

    Thanks Jeremy..what were they thinking?
    I am worried about the NG plugin it was so 'original wordpress' ;)

  6. NatalieYoung
    Member
    Posted 1 year ago #

    strange, clicking dismiss worked for me. i only saw it once. just in case it pops up again for me, are you guys up to date on wordpress? what other plugins do you have installed and what browsers are you using?

  7. JeremyKerr
    Member
    Posted 1 year ago #

    Hey Natalie...

    I tried 3 different browsers and all did the same. IE, Chrome, Firefox.

    The only other thing that I had running was a fresh install of WordPress, Buddypress and NextGen. I have since added other things but when I installed NextGen that was it.

  8. cliveohagan
    Member
    Posted 1 year ago #

    Thanks Jeremy, that worked fine. easy fix!

    Clive

  9. NatalieYoung
    Member
    Posted 1 year ago #

    interesting... one other thought i had @jeremykerr... what is your url string like? meaning, do you have a 'www' in front of your domain name, or does it load without. if you were to go to your site does your domain look like:

    http://example.com
    or
    http://www.example.com

  10. JeremyKerr
    Member
    Posted 1 year ago #

    Hey Clive...

    No prob! :)

    Hey Natalie...

    My site loads both ways. With and without the www in the front.

    Thanks!

    Jeremy

  11. NatalieYoung
    Member
    Posted 1 year ago #

    which one redirects to which? does the www url result w/o it or the other way around. if i were to go to your site, how does your url load? i understand that both lead your site, i'm just wondering how it loads by default.

  12. JeremyKerr
    Member
    Posted 1 year ago #

    Here is my url's (mind you it is still under construction)

    http://sporkdom.com

    http://www.sporkdom.com

    In the end it loads with the www in the front.

  13. NatalieYoung
    Member
    Posted 1 year ago #

    ok, the w/o www is redirecting to www. interesting. i have tested on each type of domain url on my server and the 'dismiss' works for me. thanks for sharing your site, i was just curious if that had anything to do with why it wasn't working for you. +1 on the superman trailer on your site, i am SO excited to see that movie!

  14. JeremyKerr
    Member
    Posted 1 year ago #

    Thanks! :)

  15. kittcreative
    Member
    Posted 1 year ago #

    Thanks.

  16. frameitsam
    Member
    Posted 1 year ago #

    Good Grief this is driving everyone crazy! I've got a right mind to find something else if the folks at Photocrati aren't willing to fix this themselves. I have hundreds of installations of NextGen, and this is so **BLEEPING** annoying.

    Thanks JeremyKerr for the solution. I have a lot of changes to make.

  17. JeremyKerr
    Member
    Posted 1 year ago #

    No problem. :)

  18. jano_mentor
    Member
    Posted 1 year ago #

    Hi,

    There is another pop up like this, it´s on the "add new Gallery"

    The pop up say

    "Client side resize

    You can now resize the images before you start with the upload."

    How can i delete it?

    Thanxs!!!

  19. JeremyKerr
    Member
    Posted 1 year ago #

    Hey Jano...

    That can be found in the pointer.php file right at the top of the code. It looks like this:

    // create an array if pointers for each page
     		$this->pointers = array(
    			'nggallery-add-gallery' => array(
    				'id'	   => 'image_resize_pointer',
    				'content'  => __('<h3>Client side resize</h3><p>You can now resize the images before you start with the upload.</p>', 'nggallery'),
                    'posititon'=> 'top'
    			)
    		);
    
    $page =  ( isset($_GET['page']) ) ? $_GET['page'] : '';
            $this->settings = ( isset( $this->pointers[$page] ) ) ? $this->pointers[$page] : array();
    
            add_action( 'admin_enqueue_scripts', array( &$this, 'enqueue' ) );
    	}

    I have not seen the pop up myself and I do not know what would happen if you commented out the lines of code. I would make a backup of the file, place // in front of each line and save it. I would not delete the code straight out and try it though.

    Once you do that try the "add new gallery" area and see if it still pops up or if you get any errors.

  20. hollyveld
    Member
    Posted 1 year ago #

    Just started to get this annoying pop-up after most recent update... this worked a treat. THANKS Jeremy! :-)

  21. JeremyKerr
    Member
    Posted 1 year ago #

    No problemo :)

  22. adambanaster
    Member
    Posted 1 year ago #

    had the same problem. they just released an update last day or two with a fix for it: http://www.nextgen-gallery.com/nextgen-gallery-1-9-6/. seemed to do the trick. may want to check if you still have the issue after updating to 1.9.6.

  23. JeremyKerr
    Member
    Posted 1 year ago #

    Yeah it says:

    Bugfix: Fixed an issue with users not being able to dismiss the “Photocrati Acquisition Notice”

    So they probably fixed it. :)

  24. mjm4842
    Member
    Posted 1 year ago #

    I still have the same issue in a copy of 1.9.6 that I installed today. One I installed last week doesn't seem to have the problem. Not sure what the difference is.

  25. JeremyKerr
    Member
    Posted 1 year ago #

    I looked into the new code for the updated files. I see that that line in not commented out as I believe they had fixed the issue. You can try and comment out the same line I mentioned above and see if that works.

  26. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jeremy and all,

    We did introduce a fix in 1.9.6, but a small number of people are still having some difficulties closing the box or getting it to stay closed. There's a another thread on this issue with some longer responses from us here:

    http://wordpress.org/support/topic/plugin-nextgen-gallery-nextgen-gallery-aquisition-announcement?replies=9

    It includes some trouble shooting steps plus the same short term fix that Jeremy also suggested above for those who are still having the issue.

    Thanks and best,
    Erick

  27. JeremyKerr
    Member
    Posted 1 year ago #

    Thanks Erick for the info. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic