WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Images don't display after moving wordpress (12 posts)

  1. drinkliverpool
    Member
    Posted 3 years ago #

    I have recently moved my wordpress installation from an ad-on domain to a primary domain on cPanel. Since this move, none of my images are displaying but are still present on the server. All I see on the pages is the image title.
    Help me someone, I have 599 images not showing.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. hedronist
    Member
    Posted 3 years ago #

    A link to your site would help us help you.

    I suspect you (or the plugin) stored paths that included some absolute path and/or domain information. Do a View Source in your browser (control-U in FF, alt-v c in MSIE) and see if the img tags have old path/domain info in them.

  3. drinkliverpool
    Member
    Posted 3 years ago #

    I've fixed it. It was a permissions problem. I just made them 777 and now they show up fine. Thanks anyway.

  4. carlos4444
    Member
    Posted 3 years ago #

    sry but what means "made them 777" ??

    beacause mabye that would be the solution for my problem...

  5. hedronist
    Member
    Posted 3 years ago #

    Start reading here: http://codex.wordpress.org/Changing_File_Permissions. Start a new question if that doesn't handle your problem.

  6. drinkliverpool
    Member
    Posted 3 years ago #

    CARLOS.
    Go into cPanel or whatever your host uses and locate the folder where your NextGen images are stored. If you use cPanel, on the far right o each file will be some numbers, these are the FILE PERMISSIONS. They'll probably read 0644. You will need to change these to 0777 to make the images visible.

    To change all at once, click on SELECT ALL and then right click the highlighted files and then select CHANGE PERMISSIONS and check all the boxes so the numbers read 777. You may want to do this to the folder too.

    If you don't use cPanel, there should be something similar to enable you to change the permissions.

  7. carlos4444
    Member
    Posted 3 years ago #

    what shall i say:

    THANK YOU GUYS SOO MUCH!

    this really solved my problem - i really thank u guys!!

    GREAT!

  8. drinkliverpool
    Member
    Posted 3 years ago #

    Glad to be of assistance.

  9. chooseamc
    Member
    Posted 3 years ago #

    I have a similar issue. The images upload, thumbs get created, but nothing shows up on the site except the "broken image link" box. View source shows the path is perfect. Images are all there in the correct files on the server. Permissions are set to 777. Requesting an image just hangs showing "Loading"

    I can show a singlepic no problem though.

    http://www.friendsofgoldbutte.org/photo-gallery

    Other thoughts?

  10. hedronist
    Member
    Posted 3 years ago #

    @chooseamac:

    a) you should start a new thread, not restart one that's a few weeks old.

    b) I looked at your site and all of the thumbnails + main images in the gallery are 404 (page not found). So either the URL was correct, but the images were not/could not be created (probably a permissions problem, see above), or they were created, but not in the directory referenced by the img tags (configuration / programming error). They are all of the form:

    http://www.friendsofgoldbutte.org/wp-content/gallery/february-2011/thumbs/thumbs_dsc_3874.jpg which links to
    http://www.friendsofgoldbutte.org/wp-content/gallery/february-2011/dsc_3874.jpg

    I would go looking for those files. They might be somewhere else below wp-content/gallery, in (or below) wp-content/uploads, or maybe somewhere below wp-content/themes/rttheme13/. If you can find them, then it's either a configuration problem with NGG, or it's a programming error.

  11. chooseamc
    Member
    Posted 3 years ago #

    Thanks for the thoughts. All the pictures are there (in wp-content/gallery) - all the links are correct. Doing deeper research, the error is actually a 403 (access forbidden) even though permissions are set to their loosest. It's host specific, so I'm calling them tomorrow to find out more.

  12. hedronist
    Member
    Posted 3 years ago #

    Ah! You're correct. I was not paying attention.

    I shoulder-surfed up the path and http://www.friendsofgoldbutte.org/wp-content/gallery/ also returns 403, but (as expected) http://www.friendsofgoldbutte.org/wp-content/ does not.

    A 403 might indicate a .htaccess problem. Another possibility is that there is a symlink (symbolic link) in the path and that those are not permitted by your hosting service.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.