WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
I'm getting a Fatal Error When uploading images (10 posts)

  1. areach
    Member
    Posted 2 years ago #

    When uploading images I get the following error message:

    ERROR: filename.jpg
    Fatal Error: Call to undefined function wpcf7_add_tag_generator() in /home/content/r/e/a/reachesfar/html/wp-content/plugins/contact-form-7/modules/test.php on line 152

    So, it doesn't upload the image bu strangely it adds 7 gallery thumbnails all of which have been previously uploaded and already exist in the gallery.

    Anybody know how to fix this problem. Any help would be greatly appreciated

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    That's a Contact Form 7 issue. Try re-uploading a fresh, unpacked, copy of the CF7 plugin to wp-content/plugins using FTP.

  3. areach
    Member
    Posted 2 years ago #

    Thanks for the reply and your help. Not sure how to do what you are saying. Should I uninstall the CF7 plugin first? Could I then re-install through the plugin admin panel? If not this way could you give me some instructions on how to get a fresh unpacked copy of the CF7 plugin to upload to /wp-content/plugins/contact-form-7/.
    Really appreciate your help.

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    If you can manage setting up your forms again, try deactivating and then deleting CF7. Check to see if you have any errors. Then finally, re-upload CF7 and activate it. Check again for errors.

  5. areach
    Member
    Posted 2 years ago #

    I did that and it did not give me the error and added the image to the gallery. But still one more glitch is happening. When I upload a single picture and then go to the gallery manager and into the gallery that it was added to, an additional 7 more thumbnails are added at the same time. These 7 images are already in the gallery so it's making duplicates of them. Any idea on what might be causing this. If I deactivate and uninstall the NextGen Gallery plugin and then reinstall, will I loose all the galleries I've set up already and showing on my site?
    Sorry for asking so many questions. Here's a link to my Galleries. Thought you might like to see my art. http://www.andrewreach.com/?page_id=29
    Thanks again.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

    I think it would be best if you posted a fresh topic about this issue. I have no direct connection with NextGen Gallery. I only dropped in to help out with your Contact Form 7 issue as I'm a long-time user of that plugin.

  7. areach
    Member
    Posted 2 years ago #

    I"ll do that. Thanks again for your help.

  8. Roger Stowell
    Member
    Posted 2 years ago #

    I'm getting HTTP error when I try to upload correctly sized jpegs from my computer. I have no problem uploading the same images, singly, into my WordPress site.

  9. Roger Stowell
    Member
    Posted 2 years ago #

    I seem to have succeeded in uploading the images by using a Zip file.

  10. bluelleo
    Member
    Posted 2 years ago #

    It probably conflicts with contact form 7 plugin.

    You can try:
    Change the last line in NextGen's ngg-config.php file from
    require_once( WP_LOAD_PATH . 'wp-load.php');
    to:
    require_once( WP_LOAD_PATH . 'wp-admin/admin.php');

    source: http://wordpress.org/support/topic/plugin-nextgen-gallery-conflict-with-contact-form-7?replies=37

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic