WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
HTTP Error when uploading multiple files (15 posts)

  1. regenpfeifer
    Member
    Posted 2 years ago #

    Hello,

    I have installed NextGen Gallery for a WordPress blog hosted on my own server: Ubuntu 10.04 LTS, Apache 2.x, MySQL 5.1.63, PHP 5.3.2.

    Everything works fine, but when I am trying to upload multiple pictures with the batch uploader, I'm getting the error: "Error. HTTP-Fehler: HHTTP Error".

    I have found several other threads dealing with this problem and suggesting to adapt the .htaccess files, but none of those suggestions has solved my problem.

    As it is my own server I could try to adapt permissions or other modifications, but I do not know where to start. Is there a tutorial or FAQ dealing with the prerequisites NextGen needs?

    Thank you for any hints!
    Hermann Josef

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. aloeroot
    Member
    Posted 2 years ago #

    I am having an identical problem. I just installed the plugin after upgrading to 3.4 and am wondering if it's not yet compatible with the new version.

  3. regenpfeifer
    Member
    Posted 2 years ago #

    Thank you aloeroot for your message. Maybe we will have to wait for an update?

  4. aloeroot
    Member
    Posted 2 years ago #

    It's possible. I just got it to work by turning off the Flash uploader and uploading one file at a time via the other method.

  5. regenpfeifer
    Member
    Posted 2 years ago #

    Yes, this works for me too. But it seems a bit tedious for a larger number of pictures...

  6. bluelleo
    Member
    Posted 2 years ago #

    It probably conflicts with contact form 7 plugin.

    You can try:
    Change the last line in NextGen's ngg-config.php file from
    require_once( WP_LOAD_PATH . 'wp-load.php');
    to:
    require_once( WP_LOAD_PATH . 'wp-admin/admin.php');

  7. regenpfeifer
    Member
    Posted 2 years ago #

    Thank you, bluello for your answer.

    I have installed Contact Form 7 in this blog. But unfortunately, neither the deactivation of CF7 nor your fix solves the problem.

    Yours, Hermann Josef

  8. TheOwlLady
    Member
    Posted 2 years ago #

    I am having the same problem as everyone else and use contact7. I turned off flash and uploaded one at a time and that worked, but as regenfeifer says that is tedious. I am not about to do any changes in my coding, as I am not familiar with doing this. I would probably screw up the whole website!!! Are there any other options? I am currently using another gallery and would certainly like to switch to NextGen.

  9. bluelleo
    Member
    Posted 2 years ago #

    If you deactive your contact form 7 plugin, and the nextgen uploader work. Mostly it conflicts with contact form 7 plugin.
    Then you should change the last line in NextGen's ngg-config.php file.

    require_once( WP_LOAD_PATH . 'wp-load.php');
    to:
    require_once( WP_LOAD_PATH . 'wp-admin/admin.php');

    source: http://wordpress.org/support/topic/plugin-nextgen-gallery-conflict-with-contact-form-7?replies=37

  10. bluelleo
    Member
    Posted 2 years ago #

    If you are not familiar with the code, another alternative way will be:
    1. You may downloaded and reinstalled Contact Form 7 version 3.1.2 (the previous working version) from here:
    http://downloads.wordpress.org/plugin/contact-form-7.2.4.6.zip or
    http://wordpress.org/extend/plugins/contact-form-7/developers/

    or
    2. Upload the images via Zip file.

    hope it help.

  11. localsalescreator.com
    Member
    Posted 2 years ago #

    Hi I have the same issue but I use WPMU does anybody know if i deactivate and delete Contact form 7 from the network will it delete all the forms on the sites?

    Example some plugins can be deleted and reinstalled and they pick up where they left off but because Contact form 7 uses short codes i am not sure if it will work in the same way.

  12. bluelleo
    Member
    Posted 2 years ago #

    Hi regenpfeifer,

    If you deactived your contact form, and the problem still there..
    It probably due to the memory_limit in php.ini file.

  13. bluelleo
    Member
    Posted 2 years ago #

    Hi localsalescreator.com,

    I have try deleted and reinstalled the contact form 7. The shortcode and the form is different after reinstalled. You will need to refill the fields again.

  14. regenpfeifer
    Member
    Posted 2 years ago #

    Hello bluello,

    thank you for your answer. The memory limit in my php.ini-file is 512MB, this should be enough...

  15. TheOwlLady
    Member
    Posted 2 years ago #

    Wow, that worked. I never edited CSS code before. I deactivated contact 7 and changed the php file and all is cool!
    thanks to everyone who helped.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic