WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: NextGEN Gallery] HTTP ERROR 412 while uploading photos (3 posts)

  1. Casey Picker
    Member
    Posted 5 years ago #

    I keep getting 'HTTP ERROR 412' when I try to upload photos using the flash-based uploader. Here are the settings in my php.ini file, which I suspect might be the culprit:

    file_uploads = On
    upload_max_filesize = 25M
    post_max_size = 25M
    max_execution_time = 600
    max_input_time = 600
    memory_limit = 20M
    safe_mode = 0

    Has anyone else run into this problem before?

  2. Casey Picker
    Member
    Posted 5 years ago #

    This solved my issue:

    SOLUTION:
    If you’re happy editing your blog’s .htaccess file, try adding this to the end of the file:

    <IfModule mod_security.c>
    <Files upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    NextGen uses a file called upload.php for handling uploads, and this code should disable mod_security on that file.

  3. WEB11
    Member
    Posted 5 years ago #

    I am having a smilar problem. Can you please post your entire .htacess file here and version of php? I managed to screw mine up and I don't have a backup.
    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.