WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] How can i stop the autostart from Slideshow (5 posts)

  1. sensen
    Member
    Posted 5 years ago #

    I have more slidshows on a page and i did not want to start all slideshows on start.

  2. Alex Rabe
    Member
    Posted 5 years ago #

    You need to change the script for that,

    nggfunctions.php -> nggShowSlideshow()

    add

    $swfobject->add_flashvars( autostart, 'false');

  3. pddoctor
    Member
    Posted 4 years ago #

    Hello, I love the nextGen Gallery.
    I have the same desire to stop the autostart from slideshow.

    I changed the nggfunctions.php as above but the slideshow still starts automatically. Can you help me?

    I added $swfobject->add_flashvars('autostart', 'false'); below
    // adding the flash parameter

    it didn't work.

    and I also tried to insert

    $swfobject->add_params('autostart', 'false');

    into
    // init the flash output

    But still doesn't work.

    Thanks a lot.

  4. RickA99
    Member
    Posted 4 years ago #

    @pddoctor

    It looks like you can add it anywhere that you see a list of similar lines in nggfunctions.php. It worked for me. Here's where I put it:

    $swfobject->add_attributes('styleclass', 'slideshow');
    $swfobject->add_attributes('name', 'so' . $galleryID);

    //keep slideshow from autostarting
    $swfobject->add_flashvars( autostart, 'false');

    // adding the flash parameter
    $swfobject->add_flashvars( 'file', NGGALLERY_URLPATH.'xml/imagerotator.php?gid=' . $galleryID );
    $swfobject->add_flashvars( 'shuffle', $ngg_options['irShuffle'], 'true', 'bool');

  5. sibelius
    Member
    Posted 4 years ago #

    I can't find the nggfunctions.php in the NexGEN Gallery plugins' editor.
    Should i be looking somewhere else to keep the slideshow from autostarting?
    Did this topic got resolved?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.