WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: NextGEN Gallery] Firefox 3.6 Compatbility Issue. Clicking on gallery scrolls page up to top (25 posts)

  1. remotay
    Member
    Posted 4 years ago #

    I tested this on 3 of my computers. Two with the new Firefox 3.6 and one with 3.5. On both 3.6 machines clicking on a gallery image with the shutter effect on and then exiting the image by clicking on it will force the page all the way to the top. Even if you had to scroll down to click on the image.

    Is anyone else having this problem? I'm having this issue on every site with Nextgen gallery.

    Example [Some random site] http://karenblundell.com/web-tools-wordpress/nextgen-gallery-plugin-and-widget-for-wordpress

    Clicking on an image then closing it by reclicking on it will force you to scroll to the top of the page. Happens on all my sites as well ONLY On firefox 3.6 [just released].

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. remotay
    Member
    Posted 4 years ago #

    I have the same problem on http://nextgen-gallery.com/nggallery/page-8/album-1/gallery-1/

    Tested on multiple machines. Anyone else want to confirm this bug?

  3. remotay
    Member
    Posted 4 years ago #

    I confirmed this buy with numerous friends, anyone know a workaround?

  4. cdpayne
    Member
    Posted 4 years ago #

    Don't use Firefox 3.6 ?

    I have confirmed site acts properly under Chrome, Safari and even Internet Explorer...

  5. cdpayne
    Member
    Posted 4 years ago #

    I have submitted a bug to Firefox

    http://support.mozilla.com/en-US/kb/Websites+look+wrong

    using "Report Broken Web Site" stating browser doesn't function as expected.

  6. remotay
    Member
    Posted 4 years ago #

    I don't use Firefox 3.6, but Lots of people do, as it's the newest version of Firefox. All webmasters that use Nextgen gallery are being adversely affected by this bug.

  7. cdpayne
    Member
    Posted 4 years ago #

    Yeah, I use it alot in my site development because of the right developer tools available although I find myself using the Chrome Beta more and more as it has fantastic dev tools.

    I don't think it is fair to make a blanket statement like "All webmasters that use Nextgen gallery are being adversely affected by this bug." though, maybe preface it with anybody using shutter.

    If it bugs the web developers enough they should submit bug reports, if Firefox doesn't know about the problem they can't fix it. It renders properly in the other browsers so there must be something in the FF code base to affect this behaviour. I have never submitted anything to them before so I don't know the whole process, I just searched for reporting bugs and took the liberty of submitting it for you.

    It isn't a problem on my site as I don't use shutter.

  8. remotay
    Member
    Posted 4 years ago #

    OMG! AFTER 3+ HOURS OF FIDDELING WITH shutter-reloaded.js I FIXED THE PROBLEM!

    1) I know ABSOLUTELY nothing about Javascript. I literally just played around, changed variables, deleted lines to see what happened.

    I have NO Idea whether my fix has any other adverse effects or not, so maybe someone can comment?

    To fix the problem, remove

    document.documentElement.style.overflowX = '';

    that entire line. Delete that bit, save, and upload and problem fixed! Anyone want to tell me what that line does? And will removing it break anything else? So far everything looks peachy on my end.

    Yes, I'm excited. I fixed something when I had no idea what I was doing :). Took hours of screwing around!

  9. pazderajr
    Member
    Posted 4 years ago #

    great, it works
    there is a link to edited shutter-reloaded.js
    http://www.judatenis.com/wp-content/plugins/shutter-reloaded/shutter-reloaded.js

  10. thedrewseum
    Member
    Posted 4 years ago #

    You are amazing! Worked for me as well, a real life saver :) Thank you! I will link to this thread in the one I commented on earlier today.

  11. owstopit
    Member
    Posted 3 years ago #

    Thanks for figuring this out! I've noticed that the page still scrolls to the top, but then scrolls back down. If you also take out the line:

    window.scrollTo(0,t.Top);

    It will no longer do this, and will simply stay in one place. Thank you SO MUCH for figuring this out!

  12. soleil_levant
    Member
    Posted 3 years ago #

    Not resolved. This workaround don't works for me (WP 3.0.1_FR, FF 3.6.8).

  13. remotay
    Member
    Posted 3 years ago #

    Solel_Levant

    I'm using the latest version of wordpress on another one of my sites, and my work-around works perfectly fine.

    You must use shutter reloaded and remove document.documentElement.style.overflowX = '';

    make sure to save and re-upload, because it does fix the problem on the latest WP version.

    @Owstopit
    Mine just goes up then back down on the first image, After that, new clicks on the same page don't go up then back down. Removing window.scrollTo(0,t.Top); did not fix it for me, but it's not a big issue anyway. I'll mess with it more later. Which line did you remove window.scrollTo(0,t.Top); from? it's on multiple lines.

  14. thedrewseum
    Member
    Posted 3 years ago #

    Just did the NextGen upgrade & the glitch came back. I had to go into the shutter-reloaded.js file and once again remove that line. Works perfectly now though.

    For quick reference, that file is in wp-content/plugins/nextgen-gallery/shutter/

  15. anitasavio
    Member
    Posted 3 years ago #

    Where do I find this code? I did try clicking on plugins/edit in the admin panel of my WordPress website, but could not find any line that says: document.documentElement.style.overflowX = '';(Please note, I do not know html.)
    I did find some references to "shutter-reloaded," e.g.
    // activate modified Shutter reloaded if not use the Shutter plugin
    if ( ($this->options['thumbEffect'] == "shutter") && !function_exists('srel_makeshutter') ) {
    wp_register_script('shutter', NGGALLERY_URLPATH .'shutter/shutter-reloaded.js'.

  16. soleil_levant
    Member
    Posted 3 years ago #

    @remotay
    Sorry, it works fine now after an upgrade of NG. Do you think there is somme collateral damage to remove this line ?

    Thanks

  17. mfieldhouse
    Member
    Posted 3 years ago #

    Here's a way to fix it without deleting any code, just changing a few settings. This will also give you a light box with a close button which I think is easier to use.

    1. Download the JW image rotator. Upload the imagerotator folder to your web server.

    2. In the WordPress admin go to Gallery > Options > Slideshow. Configure the path to the imagerotator.swf. For example: http://www.plansforextensions.com/imagerotator/imagerotator.swf

    Click save changes

    3. Go to Gallery > Options > Effects. Change JavaScript Thumbnail effect: to 'Thickbox'. Save changes.

    4. The problem is now fixed and you have a nicer lightbox :)

    5. Some extra text may appear before your thumbnails, something like - [show in slideshow]. To remove this, go to Gallery > Options > Gallery. Remove all text in the first box next to 'Integrate Slideshow'.

    6. Excellent!

  18. worldadultservices
    Member
    Posted 3 years ago #

    to fix this bug simply add the word "hidden" between the single quotes
    for all instances of the line
    document.documentElement.style.overflowX = ''; to document.documentElement.style.overflowX = 'hidden';
    the page will not move and everything works as it's supposed to.

  19. Maggiemoo
    Member
    Posted 3 years ago #

    This is driving me mad! Could you please treat me as the idiot I obviously am and please direct me to where I can find this code so I can fix it - please!

  20. anitasavio
    Member
    Posted 3 years ago #

    Hello Maggiemoo. I'm just in the process of teaching myself website development, so am still a novice like you. But here is what I THINK is the situation. Basically, you are going to need two programs to fix this problem. The file you are looking for is located on the server of your web host. In order to get to this file, you need to use a type of program called FTP client. FTP client programs allow your computer to interact with your web host server. There are many FTP client programs, and they can be downloaded for free from the Internet. HOWEVER, here's the problem. It appears to me that the NextGen plugin was written with Adobe Dreamweaver. (At any rate, when I try to open the "shutter reloaded" document, it tells me that I need Dreamweaver to do so.) And Dreamweaver costs about $400! As I said, I'm still a novice, so perhaps I'm doing something wrong. I'm going to send the link to this thread to the person who has been helping me with my website (she's an expert), and see if she has anything helpful to add.

  21. anitasavio
    Member
    Posted 3 years ago #

    Come to think of it, you can download a 30 day free trial version of Dreamweaver. But let's hold off till we see what my "mentor" has to say.

  22. DesignByKiltz
    Member
    Posted 3 years ago #

    @Maggiemoo

    1st, you don't need to have Dreamweaver to fix the problem. You can do it with Notepad.

    You'll find the file that needs changing in the path that @thedrewseum provided.

    I fixed it by commenting out all the lines (even if they were repeats) that have been mentioned in the above post & then tweaking with the NextGen gallery settings.

    To get to the file mentioned you need to FTP into your site using an FTP program like FireFTP (a free extension available for Firefox). Download the file to your desktop, make the changes, & just for safety sake in case you make a mistake, make a copy of the original file on the server before you upload the original one.

    If you're not comfortable mucking with code -- because in this case you're looking at coding beyond basic html & a single quote mark or semi-colon makes or breaks it :) -- find someone who is comfortable with it & have them make the changes.

    HTH
    Christy

  23. Maggiemoo
    Member
    Posted 3 years ago #

    Thank you so much! I've downloaded FireFox, gone onto my editor WP through FireFox and pulled up the 'nextgen-gallery/shutter/shutter-reloaded.js' which has the word '(inactive)' next to it. I've deleted every occurrence of the 'document.documentElement.style.overflowX = ''; after trying to change it to document.documentElement.style.overflowX = 'hidden';
    I've updated and then gone onto my site, onto the Gallery and it's still scrolling. So I ensured that I got rid of anything that said 'window.scrollTo(0,t.Top);'

    Then again, I've gone onto my site and it still scrolls up between photos like I've actually done nothing at all. I've obviously missed something out! The fact that it has '(inactive)' in the title is also a little concerning!

    Any ideas please?

    Thank you so much for your help, I really appreciate it and sincerely hope that my obvious 'thickness' proves to be a challenge to you rather than annoys!!

  24. pcland
    Member
    Posted 3 years ago #

    Thanks so much everyone!

    I changed
    document.documentElement.style.overflowX = ''
    to
    document.documentElement.style.overflowX = 'hidden'
    cleared my cache but still did not see any change.

    I then deleted the line
    window.scrollTo(0,t.Top)
    cleared my cache and still did not see any change.

    I went back and deleted
    document.documentElement.style.overflowX = 'hidden'
    cleared my cache but still no change.

    Finally, I went to a different gallery and saw that it was no longer scrolling back to the header when I closed an image. Perfect!

  25. mchilders
    Member
    Posted 3 years ago #

    I noticed lots of posts with people that weren't able to get this working correctly... I had the same issues, made all the changes and re-uploaded the js file and still not fixed.

    I realized that I had the shutter_reloaded plugin installed in wordpress along with Nextgen gallery. There is also a shutter-reloaded.js file in this plugging directory that it was using rather than the one in the nextgen gallery plugin directory. Making the changes to this file fixed it for me. I only had to add "hidden" to the document.documentElement.style.overflowX lines (two changes) and it works like a charm. Thanks for the help.

    My shutter_reloaded.js was located in:
    /wp-content/plugins/shutter-reloaded

    HTH,
    Matt

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.