WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] Error When Creating Thumbnails (9 posts)

  1. PeaElAre
    Member
    Posted 6 years ago #

    getting the following at the thumbnail creation point:

    Fatal error: Out of memory (allocated 33030144) (tried to allocate 10368 bytes) in (server path edited)/wordpress/wp-content/plugins/nextgen-gallery/lib/thumbnail.inc.php on line 183

    server settings:

    * Operating System : Linux
        * Server : Apache/1.3.34 Ben-SSL/1.55
        * Memory usage : 8.3 MByte
        * MYSQL Version : 5.0.51-log
        * SQL Mode : Not set
        * PHP Version : 5.2.5
        * PHP Safe Mode : Off
        * PHP Allow URL fopen : Off
        * PHP Memory Limit : 40M
        * PHP Max Upload Size : 20M
        * PHP Max Post Size : 8M
        * PHP Max Script Execute Time : 50000s
        * PHP Exif support : Yes ( V1.4 )
        * PHP IPTC support : Yes
        * PHP XML support : Yes
    
    GD support
    
        * GD Version : bundled (2.0.34 compatible)
        * FreeType Support : Yes
        * FreeType Linkage : with freetype
        * T1Lib Support : No
        * GIF Read Support : Yes
        * GIF Create Support : Yes
        * JPG Support : Yes
        * PNG Support : Yes
        * WBMP Support : Yes
        * XPM Support : No
        * XBM Support : Yes
        * JIS-mapped Japanese Font Support : No

    if anyone can help me, i'd greatly appreciate it. i'm not as savvy as i feel i should be and i'm in a crunch for time on getting this completed.

    thanks!

  2. Alex Rabe
    Member
    Posted 6 years ago #

    Please look at http://alexrabe.boelinger.com/2008/03/21/11-3/

    and also reduce the resolution of your images....

  3. PeaElAre
    Member
    Posted 6 years ago #

    i've looked at that article, tried all the tips therein, still having the same problem. tried phillip d's suggestion, changed to php 5 (as evidenced in the settings posted above)...

    what else?

    there's got to be a way to do this without adjusting the resolution. the whole point of installing this plugin in the first place was to not have to adjust the resolution. am i mistaken in my understanding that i shouldn't have to do that?

  4. Alex Rabe
    Member
    Posted 6 years ago #

    No, if you can't increase the memory limit, you must lower the resolution

  5. PeaElAre
    Member
    Posted 6 years ago #

    how do i increase the memory limit? is there a step noted somewhere that's not in the above linked article?

  6. Alex Rabe
    Member
    Posted 6 years ago #

    No, it's a server setting (php.ini) request this by your web hoster

  7. PeaElAre
    Member
    Posted 6 years ago #

    if you say so. i just don't get how, if i've tried everything in your above-linked article and various user comments, run the script successfully, why this doesn't work as it should.

  8. Alex Rabe
    Member
    Posted 6 years ago #

    Please ask your Web hoster if you are allowed to change the php.ini

  9. PeaElAre
    Member
    Posted 6 years ago #

    i did. they won't.

Topic Closed

This topic has been closed to new replies.

About this Topic