WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] Error: "Tables could not created..." on activation (7 posts)

  1. saganaki
    Member
    Posted 6 years ago #

    Hi all. NextGEN is a great plugin, using it on several blogs. But attempted to activate it on a new one and got this error message:

    "Tables could not created, please check your database settings"

    I've checked my database settings and the database user has full rights, etc so I'm not sure what's wrong. Anyone come up against this one before?

    Noticed some (unresolved) posts on this problem in Spanish, Korean script and Arabic - could this be a problem/bug with the database collation character set? The blog I am trying to install is jointly in Japanese so uses utf8_unicode_ci rather than std latin....

  2. saganaki
    Member
    Posted 6 years ago #

    Found the cause of the problem.

    To use the Language Switcher plugin and have a bi-lingual blog in Japanese and English required changing the DB Charset line in wp-config.php to use an extended characterset.

    From define('DB_CHARSET', 'utf8');
    To define('DB_CHARSET', 'utf8_general_ci')

    Is this a bug in the plugin itself, has anyone encountered a work around?

  3. lynze
    Member
    Posted 5 years ago #

    I have define('DB_CHARSET', 'utf8_general_ci') but the error persist. Any idea (in version 1.0)?

  4. kasperbs
    Member
    Posted 5 years ago #

    Yep same problem for me as well. Tried changing the charset, reinstalling, reactivating but no luck!

  5. solenyi
    Member
    Posted 5 years ago #

    Same here...

  6. johnstires
    Member
    Posted 5 years ago #

    I just got this on a fresh install. I have it running on 2 sites, the first on i used a while back works fine. This fresh install does not work. Both sites use the same database, both databases have the same type both versions of WP are the same.

    When I go to the NGG admin area i see this:

    Tables could not created, please check your database settings

    The script detect that you upgrade from a older version. Your database tables for NextGEN Gallery is out-of-date, and must be upgraded before you can continue. If you would like to downgrade later, please make first a complete backup of your database and the images.

    The upgrade process may take a while, so please be patient.

    I run the upgrade, it says it is successful and then throws the error again.

  7. johnstires
    Member
    Posted 5 years ago #

    nvm i just restarted my server and db and that allowed me to install

Topic Closed

This topic has been closed to new replies.

About this Topic