WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] Error installing NextGEN plugin (2 posts)

  1. smumdax
    Member
    Posted 4 years ago #

    I am getting this error upon activating the NextGEN Gallery plugin:

    "NextGEN Gallery : Tables could not created, please check your database settings"

    Using latest WordPress 2.9.1

    I tried to find help on forum and Googled it also, but can't seem to find/understand a clear and simple explanation as to what I have to do to correct this problem.

    Anyone?

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. smumdax
    Member
    Posted 4 years ago #

    I finally managed to find a solution on my own... on a Spanish website! Geez...

    This might help someone else, so here's where I found a hint to help solve:
    http://forum.plic-plac.com/index.php?topic=1587.msg6320#msg6320

    From what I understood, the plugin tries to create tables in the form of a standard WordPress installation, in which tables are named with the suffix "wp_".

    However, in my case (and probably others), I have multiple Databases and some with other WordPress installations, and so the prefix isn't the same for all. The prefix for this particular WordPress Database is "mob2_"... and so, the plugin couldn't create the tables in the form "wp_" and therefor couldn't find his tables after activating the plugin.

    So what I did was to copy the entire CREATE TABLE codes in the link above. Then I went to phphMyAdmin to find my database. In there, I sent out the query. All tables were created successfully. I then renamed the tables changing prefix "wp_" for my own "mob2_".

    After that, my plugin still gave me the error, but all the gallery menu worked. So I deactivated and reactivated the plugin.

    Error gone :)

    Hope all this is clear and will help someone else!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.