WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] doesn't work at all?! (7 posts)

  1. Jay Versluis
    Member
    Posted 5 years ago #

    Hello all,

    I'm experiencing a rather strange phenomenon. NextGen Gallery doesn't work at all on one of my sites. Let me explain.

    The plugin installs fine, activates fine, behaves fine. I can insert a gallery using the provided button, but this is the result I get:

    Warning: Compilation failed: characters with values > 255 are not yet supported in classes at offset 16 in /vhost/vhost6/v/e/r/versluis.com/www/wp-includes/shortcodes.php on line 213

    Here are my server settings:

    * Operating System : Linux
    * Server : Apache/2.0.46 (CentOS)
    * Memory usage : 11.62 MByte
    * MYSQL Version : 4.1.22
    * SQL Mode : Not set
    * PHP Version : 4.3.2
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : Off
    * PHP Memory Limit : 32M
    * PHP Max Upload Size : 100M
    * PHP Max Post Size : 100M
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    What am I up against? Does this plugin work with PHP4? Becasue I've got another server (with PHP5) and that works a treat.

    Any help appreciated!

  2. Jay Versluis
    Member
    Posted 5 years ago #

    Also, I should mention that when Next Gen Gallery generates the thumbnails, it frequently comes up with this error message - on certain images only:

    Warning: Division by zero in /vhost/vhost6/v/e/r/versluis.com/www/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 760

  3. mauvan
    Member
    Posted 5 years ago #

    Mysql and PHP versions are mentioned in the minimum requirements and that should be no problem.
    The first error concerns WP's shortcodes.php, not from the plugin.
    The second error (gd.thumbnails.inc.php) concerns a simple formula which ends by a division by zero, and that's weird.
    I'm using newer versions of PHP, and besides of that my "PHP Allow URL fopen" parameter is ON (your's is OFF), but that's only a guess.
    What's the version of GD in your graphics library?

  4. Jay Versluis
    Member
    Posted 5 years ago #

    My GD in the graphics library looks like it's 1.1.3 - here's the header:

    * gd.thumbnail.inc.php
    *
    * @author Ian Selby (ian@gen-x-design.com)
    * @copyright Copyright 2006-2008
    * @version 1.1.3 (PHP4)
    * @modded by Alex Rabe

    What's the code to change PHP Allow URL Open? I'm happy to try it. Are you running PHP4 as well? Because it works on my PHP5 server (which sadly isn't the important one).

  5. mauvan
    Member
    Posted 5 years ago #

    My GD is 2.0.28, but depends on PHP which is 5.1.6 on my side.
    PHP allow URL fopen is a part of your php.ini. It 's used to allow outside sources to be used in your programs.
    It's worth a try. But can't you also compare these settings with your other (less important) PHP5 server?
    And if you are hosted, ask them to upgrade it all. Also it's up to your web hosting company to edit php.ini in most cases.

  6. Jay Versluis
    Member
    Posted 5 years ago #

    Yes I'm hosted -

    I've actually for several different packages, older ones and some newer ones. I've just signed up with a virtual server package so will migrate everything shortly - running PHP5 of course. Then I'm in charge of php.ini ;-0

    Thanks for all your help!

  7. khag7
    Member
    Posted 5 years ago #

    was there a solution for that division by zero error? i'm getting the same thing

Topic Closed

This topic has been closed to new replies.

About this Topic