WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] Can't Install - Upgrade Loop (3 posts)

  1. misterpatrick67
    Member
    Posted 3 years ago #

    Hello all,

    I am running the latest version of WordPress and have installed the latest NextGEN. It has never been installed before. I can activate, but I get the error:

    "The script detect that you upgrade from a older version. Your database tables for NextGEN Gallery is out-of-date, and must be upgraded before you can continue. If you would like to downgrade later, please make first a complete backup of your database and the images."

    I run the Upgrade script, it says complete and then the whole thing starts all over again. I did a MySQL insert and put in all of the tables manually, but now I get the same upgrade script and it just freezes on:

    Upgrade database structure...

    So, anyone know what is going on here? The hosting is on 1and1.com and I've never had problems with running NextGEN with their hosting. Thanks!

  2. JackTheKnife
    Member
    Posted 3 years ago #

    Bump. Same problem here.

  3. hamfast
    Member
    Posted 3 years ago #

    When I installed Nextgen for the first time and tried to activate the plugin, I had the dreaded 500 error (common with 1&1 hosted sites) I fixed it with the proper php.ini and the .htaccess workarounds, and when I got into the Dashboard again I saw the plugin was already activated. Cool, I thought, but then I got the "going around in circles" upgrade loop when I access the Gallery settings, that you described.

    1&1 support suggested that I deactivate the plugin and reactivate before trying the upgrade and....it worked!

    So...Deactivate the Plugin, logout and log back in again the WP Dashboard and reactivate NextGen Gallery. The loop should now be fixed.

Topic Closed

This topic has been closed to new replies.

About this Topic