WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery] Can't generate thumbnails (88 posts)

  1. car20
    Member
    Posted 5 years ago #

    Dear alexrabe
    NextGEN Widget==>Width x Height==>40*40
    All Done , Thanks for your Kind.

    Edit:
    Sorry for post in wrong thread .( i cant see your last post )

  2. Alex Rabe
    Member
    Posted 5 years ago #

    @aapatel4
    You should resize your images before you upload them to wordpress. Then you can test if it work's with NGG.

  3. burntheweb
    Member
    Posted 5 years ago #

    I also experience problem with thumbs creations...
    I get this error message Error : Exceed Memory limit. Require : xx.xx MByte)
    any idea what i can do to check? I know I could try disabling all my plugins but the problem is that I would like to be able to upload new albums when the site is online and have to put the site offline just to upload some shots...

    Here is my config

    * Operating System : Linux
    * Server : Apache/2.2.3 (Debian) mod_ssl/2.2.3 OpenSSL/0.9.8c
    * Memory usage : 30.78 MByte
    * MYSQL Version : 5.0.32-Debian_7etch8
    * SQL Mode : Not set
    * PHP Version : 5.2.0-8+etch13
    * PHP Safe Mode : On
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 32M
    * PHP Max Upload Size : 10M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    Graphic Library

    * GD Version : 2.0 or higher
    * FreeType Support : Yes
    * FreeType Linkage : with freetype
    * T1Lib Support : Yes
    * GIF Read Support : Yes
    * GIF Create Support : Yes
    * JPG Support : Yes
    * PNG Support : Yes
    * WBMP Support : Yes
    * XPM Support : No
    * XBM Support : No
    * JIS-mapped Japanese Font Support : No

  4. aapatel4
    Member
    Posted 5 years ago #

    Thanks Alex - resize the actual image or the setting in NGG? Set the resize settings in NGG to 640x480, deleted the existing gallery and re-uploaded. Still no thumbnails.

    Hope the plug-in does not require resizing of actual images :-(. It would not be good to lessen the resolution of original images and it would take a long time...thousands of images :-(.

    thanks again for the support.

  5. Alex Rabe
    Member
    Posted 5 years ago #

    @burntheweb
    Increase the memory_limit, ask your hoster

    @aapatel4
    I'm asking for smaller images, becauses in 99% it's a memory issue

  6. aapatel4
    Member
    Posted 5 years ago #

    I am the "hoster" - running it on a Windows Home Server (WHS). I did raise the php memory limit to 1024M - re-attempted to resize as well as generate thumbnail - same result :-(. any other suggestions?

    # perating System : WINNT
    # Server : Microsoft-IIS/6.0
    # Memory usage : 13.57 MByte
    # MYSQL Version : 5.1.30-community
    # SQL Mode : STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION
    # PHP Version : 5.2.8
    # PHP Safe Mode : Off
    # PHP Allow URL fopen : On

      PHP Memory Limit : 1024M

    # PHP Max Upload Size : 2000M
    # PHP Max Post Size : 2000M
    # PHP Max Script Execute Time : 30s
    # PHP Exif support : Yes ( V1.4 )
    # PHP IPTC support : Yes
    # PHP XML support : Yes

  7. Alex Rabe
    Member
    Posted 5 years ago #

    Test it under Apache, as I can see in this thread it could be a IIS related issue. I have no IIS here, so it could be the reason for it...

  8. aapatel4
    Member
    Posted 5 years ago #

    will try to...thanks.

  9. aapatel4
    Member
    Posted 5 years ago #

    nope - same issue with Apache as well...is there anything else to try?

  10. dashdot
    Member
    Posted 5 years ago #

    Error :
    [object XMLHttpRequest]
    800 longest side no larger than 120 kbyte a picture
    get no memory limit things just the above\
    help???? thank you in advanc, kind regards

  11. Ginchen
    Member
    Posted 5 years ago #

    I have this issue, too. No thumbnails, no error message. I don't even have a progress bar - only a "0%" which is there all the time, even when not uploading. (See below)
    I also tried smaller images, even tiny ones like 17x11 pixels, but it doesn't work either.

    These are the server settings:

    * Betriebssystem : Linux
    * Server : Apache
    * Speicherverbrauch : 13.92 MByte
    * MySQL Version : 4.1.22-log
    * SQL Modus : Nicht gesetzt
    * PHP Version : 5.2.6
    * PHP Safe Mode : Aus
    * PHP Allow URL fopen : An
    * PHP Memory Limit : 40M
    * PHP Max Upload Größe : 40M
    * PHP Max Post Größe : 8M
    * PHP Max Script Execute Time : 600s
    * PHP Exif Modul : Ja ( V1.4 )
    * PHP IPTC Modul : Ja
    * PHP XML Modul : Ja

    * GD Version : bundled (2.0.34 compatible)
    * FreeType Support : Ja
    * FreeType Linkage : with freetype
    * T1Lib Support : Nein
    * GIF Read Support : Ja
    * GIF Create Support : Ja
    * JPG Support : Ja
    * PNG Support : Ja
    * WBMP Support : Ja
    * XPM Support : Nein
    * XBM Support : Ja
    * JIS-mapped Japanese Font Support : Ja

    I copied the whole blog to my local server, and everything works fine there. Here are the settings:

    * Betriebssystem : WINNT
    * Server : Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4
    * Speicherverbrauch : 16.43 MByte
    * MySQL Version : 5.0.45-community-nt
    * SQL Modus : Nicht gesetzt
    * PHP Version : 5.2.4
    * PHP Safe Mode : Aus
    * PHP Allow URL fopen : An
    * PHP Memory Limit : 64M
    * PHP Max Upload Größe : 32M
    * PHP Max Post Größe : 16M
    * PHP Max Script Execute Time : 60s
    * PHP Exif Modul : Ja ( V1.4 )
    * PHP IPTC Modul : Ja
    * PHP XML Modul : Ja

    * GD Version : bundled (2.0.34 compatible)
    * FreeType Support : Ja
    * FreeType Linkage : with freetype
    * T1Lib Support : Ja
    * GIF Read Support : Ja
    * GIF Create Support : Ja
    * JPG Support : Ja
    * PNG Support : Ja
    * WBMP Support : Ja
    * XPM Support : Nein
    * XBM Support : Ja
    * JIS-mapped Japanese Font Support : Nein

    The memory limit is higher, but I do not think that's the reason. 40M should be more than enough for a 17x11 px image, shouldn't it?

    Also, on the live server, the nice tab menu in the backend won't work. Instead, I only see ugly text links for "Create new gallery", "Upload images" etc. And as mentioned above, there is always that strange "0%" in the top left corner. See here: http://img27.imageshack.us/my.php?image=nextgen.jpg

    I don't know if that has anything to do with it - it's just another difference I noticed between my live and local server. It can't be caused by a missing css file or something, because it is really an exact copy of the version on the live server.

  12. af3
    Member
    Posted 5 years ago #

    Are you using flickrss plugin? I had similar problems before where thumbnails and images not displayed; fixed when i disabled flickrss.

  13. Ginchen
    Member
    Posted 5 years ago #

    No, no flickrss. And, why would it work on one server then and not on the other?

  14. gryffonx
    Member
    Posted 5 years ago #

    I tried various things, and the following was the only thing I could get to consistently generate thumbnails or set watermarks.

    I had to manually (read: NOT in the plugin) resize my images so that they were no longer than 600 pixels on either axis, and that the file size was not larger than 100k (saving a jpg at medium or high usually did the trick). From there I used an FTP program to re-upload the images to their correct directories. When I went into the plugin and set it to generate a thumb or watermark, it worked.

    Also note: I am on 1&1, which I know has caused issues in the past, and may also account for why some people have this problem and others don't.

  15. fisk123
    Member
    Posted 5 years ago #

    I also have problems with making thumbnails. I have set the permissions on the thumb-folder to 777 and tried with small images (17kb, 70kb, etc)
    Still there is no thumbnails created.. I tried what gryffonx said, but still no action.. My server settings are following:

    Operating System : Linux
    Server : Apache
    Memory usage : 10.62 MByte
    MYSQL Version : 5.0.32-Debian_7etch8-log
    SQL Mode : Not set
    PHP Version : 5.2.8
    PHP Safe Mode : On
    PHP Allow URL fopen : On
    PHP Memory Limit : 24M
    PHP Max Upload Size : 12M
    PHP Max Post Size : 12M
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

  16. Alex Rabe
    Member
    Posted 5 years ago #

    I need to debug this at the server, I have currently no explain for this behaviour (if it's not a memory issue). If some is interested in help, please contact me by mail

  17. urbansloth
    Member
    Posted 5 years ago #

    I've also been having trouble generating thumbnails with the latest versions of WP and NGG. At first I thought the problem was with all pictures but after more trials I realized that some worked and some did not. It had nothing to do with file size, it seems to have more to do with the width (in pixels specifically) of the image. The error message I receive is

    Fatal error: Out of memory (allocated 55574528) (tried to allocate 3778 bytes) in /hermes/bosweb/web203/b2034/sl.byronwiebe/public_html/wp-content/plugins/nggallery/lib/gd.thumbnail.inc.php on line 183

    After trying numerous pictures I realized that the second number (in this case 3778) was either the exact width of the picture (in pixels) or a multiple of it. I changed the pixel width of picture from 3776 to 3778 uploaded both pictures and, as I say, the first "tried to allocate" 3776 and the second, 3778. I am not a programmer at all, I have no idea if those numbers are supposed to align or not, it seems odd to me but maybe someone has a reason for this, or maybe this will help someone find a solution.

  18. Ginchen
    Member
    Posted 5 years ago #

    The issue with the missing menu tabs in the backend just gave me an idea: I checked all the files that NGG adds to the head and got 403 errors for all of them!

    The files I am talking about are:

    http://www.domain.com/wp-content/plugins/nextgen-gallery/admin/css/jquery.ui.tabs.css?ver=2.5.0
    http://www.domain.com/wp-content/plugins/nextgen-gallery/admin/css/nggadmin.css?ver=2.7.0
    http://www.domain.com/wp-content/plugins/nextgen-gallery/admin/js/jquery.MultiFile.js?ver=1.1.1
    http://www.domain.com/wp-content/plugins/nextgen-gallery/admin/js/swfupload.js?ver=2.2.0
    http://www.domain.com/wp-content/plugins/nextgen-gallery/admin/js/swfupload.handler.js?ver=1.0.0
    http://www.domain.com/wp-content/plugins/nextgen-gallery/admin/js/ngg.ajax.js?ver=1.0.0
    http://www.domain.com/wp-content/plugins/nextgen-gallery/admin/js/ngg.progressbar.js?ver=1.0.0

    None of these show up when I call them directly in the browser. Not even if I leave the query string at the end away. As if the files weren't there, but they are!

    Other (native WordPress) files however, do work. For example:

    http://www.domain.com/wp-includes/js/jquery/jquery.js?ver=1.2.6

    I don't know - maybe this somehow related to permalinks/mod_rewrite?

  19. lotgla
    Member
    Posted 5 years ago #

    Hi!
    I also have this problem.

    I can upload the pictures OK, even big ones, but no thumbnails are created. I get an error message saying: "Error Exceed Memory Limit. Requires 71.64 MB."

    This is independet of the size of the image, I get the same error when I have uploaded images of 600 kB for instance. So it seems as if the program somehow tries to create really huge thumbnails?

    The host I am using have a limit of 100MB and I can't change that...

    Any ideas?

  20. Moppie
    Member
    Posted 5 years ago #

    I really like NextGEN, very easy to use, however I have also been having this problem.

    I tried the following:
    Completely disabled and deleted the plug-in.
    Reinstalled latest version.

    Still had the problem.

    Reduced image from 330kb to 250kb.

    Still had the problem.

    Reduced image from 250kp to 80kb.

    and it works perfectly!

    It appears that it is a problem with my webhosts memory allocation, not sure if I can change that, or get it changed.

    This is very annoying though, as an 80kb photo does not have the same impact as a 250kb photo and artifacting is really noticable.

    Do love how NextGEN works though, so for the mean time I will stick with it, and it appears I can get away with images of around 150kb at the most.

    Server settings:

    * Operating System : FreeBSD
    * Server : Apache/1.3.29 (Unix) PHP/5.2.5 FrontPage/5.0.2.2623
    * Memory usage : 11.32 MByte
    * MYSQL Version : 5.0.22
    * SQL Mode : Not set
    * PHP Version : 4.4.8
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 32M
    * PHP Max Upload Size : 8M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    Alex, I can't find your email address, but I have lots of free time at the moment and would be happy to help anyway I can with testing.

  21. Moppie
    Member
    Posted 5 years ago #

    Yay!

    I have found a work around, it is a bit involved, but it does work.

    Resize the images to below 150k. Doesn't matter what they look like.

    Create a gallery and add the images.

    Now, using an ftp programe simply replace all of the images with larger sized and high quality ones. Just make sure they are named exactly the same.
    They can be found in /wp-content/gallery/name of gallery

    With a good ftp program and some clever workflow with photoshop and lightroom, this is not to hard to do and the resizing and renaming can be automated.

  22. codecks
    Member
    Posted 5 years ago #

    I had the same kind of problems. I deleted the whole db using the setup function, removed the pluging and reinstalled everything from scratch. It works like a charm now.

  23. mranere
    Member
    Posted 5 years ago #

    I had this same exact problem. I had three galleries in different folders all on the same server. One worked, the other two did not. I fixed it on my end by adding a .htaccess file with this in it to make sure it was recognizing I had MySQL 5.

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Also, on my overview page this entry is set to off. I noticed that on the two that did not work, this was set to ON.

    PHP Allow URL fopen : Off

    When that was set to on - it did not work.

    I am also on 1 and 1. Hope that helps.

  24. jjburke77
    Member
    Posted 5 years ago #

    OK I am seriously a newbie to WP, PHP, and MySQL so I need a little more advise. Where do I put the .htaccess file, and how do I set the PHP Allow URL fopen value to off.

    Thanks,
    Jeremy

  25. 6clicks
    Member
    Posted 5 years ago #

    For me it was just a problems off permission folder don't forget to put also permission "777" to the thumbs folder in your gallery folder.

  26. jamesgpearce
    Member
    Posted 5 years ago #

    The error you see doesn't tell you anything except that there was a problem with the AJAX generating the thumbnails.

    e.g if your AJAX post looks like this:

    _wpnonce=b67axxxxx
    action=ngg_ajax_operation
    image=85
    operation=create_thumbnail

    then the response should look like this:

    1

    Sometimes you'll get a blank response back, with no body - and it's then that you'll see [object XMLHttpRequest] as the error in the management panel.

    In other words, there may be a range of reasons why you see this error. Better error reporting would help us all.

    Personally? I can see all my thumbnails get generated, but I still get this on a random selection of the images in a gallery - even when the originals were less than 50k in size.

    So this issue, I think, still unsatisfactorily remains. ;-)

  27. jamesgpearce
    Member
    Posted 5 years ago #

    Incidentally, I notice that all my failing AJAX requests take exactly 10seconds (to the 1ms).

    So it's not permissions, or size, but seems to be some sort of weird internal timeout. (Everything's local, or so I thought...)

  28. rcpkrc
    Member
    Posted 5 years ago #

    l am also having same problem, thumbnails cant be created with big images, l dont know why, but when l upload very small images its ok without any error message but when l upload big images it returns with same memory error message... still couldnt solve it searching...

  29. creveco
    Member
    Posted 5 years ago #

    see this link
    http://www.visser.com.au/blog/thumbnail-generation-php-memory-limit-nextgen-gallery/

    uncomment line #168 remove the //) before @ini_set('memory_limit', '128M'); on /wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php

  30. Alex Rabe
    Member
    Posted 5 years ago #

    This is possible, but a lot of hoster didn't allow to set the php.ini via a script.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.