WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] After NextGEN 1.7.0 upgrade most backend functions not operational (8 posts)

  1. Ron
    Member
    Posted 3 years ago #

    After upgrading to NexGEN Gallery version 1.7.0 I am seeing major issues with several backend functions.

    Scenario:

    • Performed automatic upgrade from WP panel
    • Upgrade was reported as successful
    • Upon selection of a NextGen panel function, a notice warned of a needed database update.
    • Clicked to update database. Reported successful update

    All front end functions of existing content seem to work as before

    Issues I see now:

    • Can upload to galleries, but no thumbnails get created and no error is reported. The thumbs sub-directory itself does get created, but it is empty.
    • Manually forcing re-create thumbnail also results in nothing happening & no error message.
    • The albums admin page allows album creation and shows all content correctly, but nothing can be dragged/dropped or expanded/collapsed.
    • The add galleries/Images page no longer is tabbed. All upload options appear listed down the page all at once (all divs are visible)

    So far, everything I've seen that doesn't work just fails silently, with no error messages.

    Other notes:

    • running PHP5
    • There are no core hacks of any WP or plugin files
    • Current theme is "Constructor"
    • Only activated plugins are the following:
      Collapsing Categories, Collapsing Links, Collapsing Pages, Maintenance Mode, Mapress, My Category Order, My Link Order, My Page Order, NextGEN Gallery, Tiny MCE Advanced

    Below are my Server Setting stats:

    * Operating System : Linux (64 Bit)
    * Server : Apache
    * Memory usage : 29.28 MByte
    * MYSQL Version : 5.1.47-community-log
    * SQL Mode : Not set
    * PHP Version : 5.2.14
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 128M
    * PHP Max Upload Size : 10M
    * PHP Max Post Size : 10M
    * PCRE Backtracking Limit : 500000
    * PHP Max Script Execute Time : 300s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    Graphic Library

    * GD Version : bundled (2.0.34 compatible)
    * FreeType Support : Yes
    * FreeType Linkage : with freetype
    * T1Lib Support : No
    * GIF Read Support : Yes
    * GIF Create Support : Yes
    * JPG Support : Yes
    * PNG Support : Yes
    * WBMP Support : Yes
    * XPM Support : No
    * XBM Support : Yes
    * JIS-mapped Japanese Font Support : No

  2. mmoralesx
    Member
    Posted 3 years ago #

    I have the exact same problem...

    http://www.chunknchip.com/wp-admin/

    gives me white screen of death and I have to update client images tonight ><!

  3. mnr
    Member
    Posted 3 years ago #

    I'm wary of keeping using this plugin now with these reports.. also on a site with teh latest version pagination stopped working!

  4. Ron
    Member
    Posted 3 years ago #

    I am not getting whitescreens, only failure of certain functions.

    It looks like javascript may be failing, and it looks like the conflict is with my theme. Why would the theme affect the back-end admin functions of other plug-ins?

    This is the page error I get:

    Webpage error details
    
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)
    Timestamp: Mon, 13 Dec 2010 08:21:11 UTC
    
    Message: Object doesn't support this property or method
    Line: 99
    Char: 5
    Code: 0
    URI: http://{myurl}/wordpress/wp-content/themes/constructor/admin/js/settings.js?ver=3.0.3

    I'm running the latest WP-Constructor theme 1.3.1.

    This was all working fine before I upgraded to NextGEN 1.7.0. No errors, no issues. Something in the new NextGEN is now conflicting. I know Constructor theme was actually built to run with NextGEN for some of it's slideshow functionality.

    I've put a lot of time building my site around this theme, so I'm not really in a position to change it, which means I'm stuck right now.

  5. Alex Rabe
    Member
    Posted 3 years ago #

    The problem maybe happens due to the fact that the theme added JavaScript code to all backend pages which may causes the conflict, switch to default theme for a test

  6. Ron
    Member
    Posted 3 years ago #

    I switched to the default TwentyTen theme for a test and everything ran perfectly. Switched back and the issues return. It's definitely interaction with the theme. I also found that when I go to the theme customization options for Constructor, some of the settings do not function if NextGEN is activated.

    As for the problem scenarios - When selecting a NextGEN panel, I get the following error reported in firebug console:

    $(".constructor-accordion").accordion is not a function
    [Break On This Error] navigation: true

    The block of js code from the theme that chokes everything is:

    // Accordion
    $('.constructor-accordion').accordion({
     autoHeight: false,
     navigation: true
     });

    I don't know much about js, but this function looks pretty basic. I'm guessing there is some deeper underlying conflict that is causing the issue.

    Unfortunately I am too heavily invested in the constructor theme to change away from it now. If that theme itself is at fault, then I can try to pursue the author as I would't expect you to fix someone else's problem. However, everything ran fine with the previous NextGEN version, so I don't really know who is stepping on who's toes when it comes to the conflict.

    Any help is greatly appreciated.

    Thank You.

  7. Alex Rabe
    Member
    Posted 3 years ago #

    Contact the author of the theme, he should not add script code to backend calls

  8. Ron
    Member
    Posted 3 years ago #

    Latest Constructor theme 1.4.1 release fixes the conflict issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic