WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
404 errors on image pages when permalinks enabled (2 posts)

  1. CaliVW78
    Member
    Posted 1 year ago #

    NextGEN Gallery version 1.9.6

    When I have permalinks enabled, all of my individual image pages return a 404 error. I'm not sure that this is directly related to NextGEN, but I'm not seeing any other issues.

    Here is the default permalink structure I use:
    /%year%/%monthnum%/%day%/%postname%/

    With that enabled, I make a request to view an image. Let's say the url is:
    http://calivw78.com/pics/buses/74westy/after-body-shop/gallery/image/vandejo_6

    The URL (and subsequent 404) I get in return is:
    http://calivw78.com/pics/buses/74westy/after-body-shophttp:/calivw78.com/images/image/vandejo_6

    I'm not sure what is screwing with the URL. I've checked .htaccess files but I'm not able to find any issues. I've read a lot of folks saying that re-saving the permalinks solves their issue for a period of time, but not the case here, unless I'm disabling them entirely.

    Again, if I disable permalinks, I'm good to go. Of course, this breaks a load of URL's embedded throughout the site :)

    Anyone have any ideas?

    Thanks in advance,
    CaliVW78

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. CaliVW78
    Member
    Posted 1 year ago #

    Here is .htaccess file under the root WP directory

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    I also tried rebuilding the image structure using the "Create new URL friendly image slugs" button. No change though.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic