WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] [Plugin: NextGen Gallery] - 2.0.59 Can't Upload Images to Gallery (Js issue) (10 posts)

  1. Fred
    Member
    Posted 4 months ago #

    Hi,

    I can't upload images to galleries.
    Issue comes, apparently, from a javascript error:

    response is null, on the javascript code, created at yourdomain.com/wp-admin/admin.php?page=ngg_addgallery

    in `if(typeof(response.error) != 'undefined') {
    up.trigger('Error', {
    code: plupload.IO_ERROR,
    msg: response.error,
    details: response,
    file: file
    });
    }`

    server: gallery folder and subfolders set to 777 for tests, safemode off, php 5.3, max file upload size 300Mo

    file to upload: jpg, 140ko

    wp: 3.8.1, ngg 2.0.59, theme twentyfourteen, fresh install

    Hope it helps to solve the issue, if it is one.

    Thanks!

    https://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @Fred - Thanks for these details but we are not seeing this issue as you are describing it in any of our tests and we often start with a fresh installation using Twenty Fourteen (read: the most current default WordPress theme).

    Is this on a remote server or a local installation?

    - Cais.

  3. Fred
    Member
    Posted 4 months ago #

    Hi and thank you for your reply.

    It's on a remote server.
    I continue to investigate, but it's weird :/

    Thank you for your great plugin by the way.

  4. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @Fred - Thank you!

    If you are not able to find anything still, you are welcome to submit a Bug Report (http://www.nextgen-gallery.com/report-bug/) with the site specifics as well as log in and FTP credentials for the site so we can get a better look under the page.

    - Cais.

  5. Fred
    Member
    Posted 4 months ago #

    Thank you, I checked it again and I think it's not file permission, but system/file/folder owner rights issue.
    Will continue to see how to fix it.

    Thanks!

  6. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @Fred - Thanks for the update. Owner rights and permissions can be tricky to get sorted out. Good Luck.

    Please let us know if there is anything we can help with.

    - Cais.

  7. Fred
    Member
    Posted 4 months ago #

    Hi and thank you for your reply.

    I tested with other file permissions and contacted my hosting company.
    Still having issues.
    So I desactivated all other plugins, then it worked.
    Reactivating one by one, the issue comes as soon as I activate Qtranslate (2.5.39).

    So I guess there is a conflict somewhere...

    Hope it helps, I will see if I find someone facing the same issue.
    Or maybe you know already this issue?

    Thanks

    Fred

  8. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @Fred - Well there is some light at the end of the tunnel (hopefully). We are working on the modifications in NextGEN Gallery to allow for qTranslate to work more correctly with NextGEN Gallery.

    Currently the known issue of not being able to insert galleries with qTranslate active has the work-around of deactivating qTranslate temporarily while inserting galleries then reactivate it.

    The code modifications are still in alpha testing but we hope to have them released soon, most likely after our next release dealing with WordPress 3.9 compatibility issues.

    More details will be available on this page as they get closer to being released: http://www.nextgen-gallery.com/nextgen-gallery-latest-beta/

    Thanks!

    - Cais.

  9. Fred
    Member
    Posted 4 months ago #

    Hi thank you for your reply.
    I will check your link.
    So far, with the time I have and the time I spent, I created this code, that I placed into a really basic plugin (my own).
    And it does the job in my case.

    add_action('qtranslate_loadConfig', 'myaction', 100);
    function myaction(){
    	global $q_config;
    	if(strpos($_SERVER['REQUEST_URI'], 'ngg') !== false
    	|| strpos($_SERVER['REQUEST_URI'], 'photocrati') !== false
    	)
    	// Can maybe add this condition  in case
    	// || strpos($_SERVER['REQUEST_URI'], 'ajax') !== false
    	{$q_config['hide_untranslated'] = 0;}
    }

    Hope it helps some users

    Thanks!

    Fred

  10. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @Fred - Thanks for sharing this!

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic