WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: NextGEN Gallery 1.3.6] Force disabling PHP Safe Mode (1 post)

  1. Matt Hancock
    Member
    Posted 1 year ago #

    I'm trying to upload images to an old WordPress website (2.8.4) that's currently on a Plesk server. It's using an old copy of NextGEN Gallery (1.3.6), but I'm unable to upload files or create thumbnails.

    Here are the server settings:

    Operating System : WINNT
        Server : Microsoft-IIS/7.5
        Memory usage : 15.7 MByte
        MYSQL Version : 5.1.61-community
        SQL Mode : Not set
        PHP Version : 5.2.17
        PHP Safe Mode : On
        PHP Allow URL fopen : On
        PHP Memory Limit : 128M
        PHP Max Upload Size : 10M
        PHP Max Post Size : 8M
        PHP Max Script Execute Time : 60s
        PHP Exif support : No
        PHP IPTC support : Yes
        PHP XML support : Yes

    The weird thing is inside the Plesk Control Panel, PHP Safe Mode has been turned OFF. Here are those settings:

    safe_mode - off
    safe_mode_include_dir - Default
    safe_mode_exec_dir Default
    include_path - Default
    session.save_path - Default
    mail.force_extra_parameters - Default
    register_globals - Default
    open_basedir - {DOCROOT}\;{TMP}\
    error_reporting - Default
    display_errors - Default
    log_errors - Default
    allow_url_fopen - Default
    file_uploads - Default
    short_open_tag - Default
    magic_quotes_gpc - Default

    Is there any way to 'trick' NextGEN Gallery to say that Safe Mode is OFF?

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic