WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Custom Fields
Permission Error When Installing Custom Fields (Running Script) (2 posts)

  1. tsilliker
    Member
    Posted 3 years ago #

    I am attempting to run the following script to install this plugin:

    http://www.thecakebox.org/wp-admin/admin.php?page=nextgen-gallery-custom-fields/ngg-custom-fields.php&mode=upgrade

    I get an error stating I do not have the correct permissions to run it. My site host has looked at the problem and stated that database references provided by the developer do not mesh with the table names in the default WordPress installation. Has anyone encountered an error like this?

    WordPress version is 2.92
    Nextgen version is 1.3.5
    Custom field version is 1.0.2

    http://wordpress.org/extend/plugins/nextgen-gallery-custom-fields/

  2. zartistry
    Member
    Posted 3 years ago #

    If you follow the instructions as listed on the plug-in page or the readme file you will get this error.

    The instructions tell you to copy the file "ngg-custom-columns.php" into a directory "/wp-content/plugins/ngg-custom-columns/"

    But then the link provided for the upgrade script is to a directory "http://www.example.com/wp-admin/admin.php?page=nextgen-gallery-custom-fields/ngg-custom-fields.php&mode=upgrade"

    The directories and file names don't match up, so when you try to run the upgrade link as written it fails as that url points to a non-existent folder and file.

    Instead, after you've activated the plug-in, click on the plug-in menu link on the left hand-side of your admin page. It will take you to the url "http://www.example.com/wp-admin/admin.php?page=ngg-custom-columns/ngg-custom-fields.php" (or what ever directory you copied the php file to). Now add "&mode=upgrade" to the end of the url and press enter.

    The upgrade script will run, and you will be good to go.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic