WordPress.org

Ready to get started?Download WordPress

Forums

Network Latest Posts
[resolved] 'wrapo=' and 'wrapc=' do not work (3 posts)

  1. sergeyzimin
    Member
    Posted 2 years ago #

    Outcome for wrapo='<div class=post-content>'
    is & lt;div class="post-content"& gt;
    As we can see instead of html tags we got characters.

    http://wordpress.org/extend/plugins/network-latest-posts/

  2. sergeyzimin
    Member
    Posted 2 years ago #

    Fix:
    html_entity_decode($begin_wrap)
    html_entity_decode($end_wrap)

    By the way I didn't get why is there
    if( ( !empty($begin_wrap) || $begin_wrap != '' )
    because $begin_wrap can not be empty anyway:
    function network_latest_posts($how_many=10, $how_long=0, $titleOnly=true, `$begin_wrap="\ n
    <li>"</li>`
    , $end_wrap="", $blog_id='null', $thumbnail=false, $cpt="post", $ignore_blog='null', $cat='null', $tag='null', $paginate=false, $excerpt_length='null', $display_root=false, $auto_excerpt=false, $full_meta=false, $size = 'thumbnail' ) {

  3. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Sergey,

    This will disappear in the next version, it is a nasty hack and it turned out to be more confusing than helpful for most of the people.

    Instead of this, I added a new parameter called display_style which accept this values: olist (ordered list), ulist (unordered list), block, inline (inline blocks). That way I can control the tags used and there will be CSS styles provided for each one of those types, so people can get something styled by default or create their own styles using CSS instead.

    Cheers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.