WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Plugin network activate/deactivate is flipped (6 posts)

  1. johnbailon
    Member
    Posted 1 year ago #

    On network admin, all plugins that are deactivated are actually activated and vice-versa. Nothing really wrong other than that bug. Any ideas how to fix it?

  2. all plugins that are deactivated are actually activated

    The what now? Do you mean plugins that are deactived on /wp-admin/network but show up as active on /wp-admin/plugins.php ?

    If so... Well. Are you SURE they were network activated?

  3. johnbailon
    Member
    Posted 1 year ago #

    Yes, deactivated plugins on wp-admin/network show as active on regular websites.
    Here's a screenshot. On the left, you see the network admin's plugins page with 2 plugins deactivated. On the right, you see the regular site's plugin page with the 2 plugins activated.

    Am I SURE if they were network activated? No, I never said they were network activated. So actually, to workaround this bug, I don't network activate plugins that I want activated on the regular sites.

  4. Well then nothing's wrong.

    Network Admin: Plugins are not active.

    Subsite: Someone manually activated the plugin.

    That's what it's supposed to be :) What's wrong about this?

  5. johnbailon
    Member
    Posted 1 year ago #

    Oh! So that's how it works. My bad.

    My understanding was when a network admin activates or deactivates a plugin, it activates or deactivates respectively the plugins on the other subsites. Thanks for clarifying Mika.

  6. johnbailon
    Member
    Posted 1 year ago #

    Marking as resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic